Bug Hunting Session
Bug 77374 - FILESAVE: Saving to docx produces error
Summary: FILESAVE: Saving to docx produces error
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-12 20:25 UTC by Stefan
Modified: 2015-11-12 15:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Original docx file. (136.90 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-04-12 20:25 UTC, Stefan
Details
The adjusted file as .odt (96.25 KB, application/vnd.oasis.opendocument.text)
2014-04-12 20:27 UTC, Stefan
Details
For comparison - the .docx file exported as pdf out of Word 2010 (589.97 KB, application/pdf)
2014-04-12 20:51 UTC, Stefan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan 2014-04-12 20:25:50 UTC
Created attachment 97273 [details]
Original docx file.

Problem description: 

A file was created in Word 2010 and saved as .docx file. It includes tables and graphics. Then opened in Writer and adjusted, because some of the graphics were not in the right place. Then the file was saved as .odt file.  When trying to save the file as .docs again, the following error message appears:
Error while saving the document <document name>: No access to object.  Due to missing rights, the object cannot be accessed.

Current behavior:
File does not get saved in .docx format.  .doc is possible, but looses more formatting.

Expected behavior:
Saving the file in .docx is successful.

              
Operating System: Linux (Other)
Version: 4.2.3.3 rc
Comment 1 Stefan 2014-04-12 20:27:20 UTC
Created attachment 97274 [details]
The adjusted file as .odt
Comment 2 Stefan 2014-04-12 20:46:10 UTC
I am trying to attach more files, to make the bug more descriptive, but every time I am trying to upload another file I am getting an red bar saying, that I don't have a token for create_attachment.cgi.
Comment 3 Stefan 2014-04-12 20:51:07 UTC
Created attachment 97275 [details]
For comparison - the .docx file exported as pdf out of Word 2010
Comment 4 Stefan 2014-04-12 20:52:03 UTC
I was able to successfully attach all the files now. Please ignore https://bugs.freedesktop.org/show_bug.cgi?id=77374#c2
Comment 5 tommy27 2014-05-07 05:33:39 UTC
tested under Win7x64 using LibO 4.2.3.3

I can save adjusted .odt file to .docx without any error message.
maybe Linux specific filesave issue? please give exact details about your distro.

however there's some formatting change after .odt to .docx conversion and scrolling in the resulting .docx is very slow (it was smooth in .odt and original .docx)
Comment 6 Yousuf Philips (jay) (retired) 2014-05-27 16:26:37 UTC
Tested in Linux Mint with 4.2.4 and no problems after adjusting some images and then double save as. Maybe you can send in a screencast for this.
Comment 7 QA Administrators 2015-01-10 18:06:02 UTC Comment hidden (obsolete)
Comment 8 Timur 2015-02-03 17:12:37 UTC
(In reply to tommy27 from comment #5)
> tested under Win7x64 using LibO 4.2.3.3
> I can save adjusted .odt file to .docx without any error message.
> however there's some formatting change after .odt to .docx conversion and
> scrolling in the resulting .docx is very slow (it was smooth in .odt and
> original .docx)

Original problem with errors while saving NOT reproduced. 

There are multiple problems with original DOCX file in attachment 97273 [details]:
1. Original problem with errors while saving NOT reproduced. 
2. 1st page table cell frame lost on import starting from LO 4.0 beta1 up to 4.5.0 master - reported in Bug 79329.
3. Last page and last section text (starting from "Ihre kleine Schwester...") lost on import starting from LO 4.4.0 beta1 and confirmed with LO 4.5.0 master - reported as Bug 89088
4. Filesave as DOCX looses text, so 7 pages is saved as 3 pages, but not easy to determine from which version, because: 
- up to 4.1 text was NOT lost
- 4.2 didn't open docx properly at all up to 4.2.2, there were not 7 pages, but it was fixed and text is NOT lost after that up to now with 4.2.8
- text IS lost in 4.3 up to 4.3.6 and 4.4 up to 4.4.0
- text is NOT lost again in 4.5.0 master
I set as "regression" because it worked fine, and mark version as 4.3.0. becase current behavior started there. I mark as Critical because of data loss.
Further testing desired and possible backport of fix to 4.4 and 4.3.
Comment 9 Robinson Tryon (qubit) 2015-03-05 17:35:27 UTC
(In reply to Timur from comment #8)
> (In reply to tommy27 from comment #5)
> > tested under Win7x64 using LibO 4.2.3.3
> > I can save adjusted .odt file to .docx without any error message.
> > however there's some formatting change after .odt to .docx conversion and
> > scrolling in the resulting .docx is very slow (it was smooth in .odt and
> > original .docx)
> 
> Original problem with errors while saving NOT reproduced. 

Okay, then this bug report should probably be RESOLVED.

> There are multiple problems with original DOCX file in attachment 97273 [details]
> [details]:

This is starting to turn into a tracking-bug for a bunch of different issues. Please try to stick to one problem per bug report.

> 1. Original problem with errors while saving NOT reproduced. 
> 2. 1st page table cell frame lost on import starting from LO 4.0 beta1 up to
> 4.5.0 master - reported in Bug 79329.
> 3. Last page and last section text (starting from "Ihre kleine
> Schwester...") lost on import starting from LO 4.4.0 beta1 and confirmed
> with LO 4.5.0 master - reported as Bug 89088
> 4. Filesave as DOCX looses text, so 7 pages is saved as 3 pages, but not
> easy to determine from which version, because: 
> - up to 4.1 text was NOT lost
> - 4.2 didn't open docx properly at all up to 4.2.2, there were not 7 pages,
> but it was fixed and text is NOT lost after that up to now with 4.2.8
> - text IS lost in 4.3 up to 4.3.6 and 4.4 up to 4.4.0
> - text is NOT lost again in 4.5.0 master
> I set as "regression" because it worked fine,

what worked fine?

> and mark version as 4.3.0.
> becase current behavior started there. 

which 'current behavior' ? All of the problems described in comment #8?

> I mark as Critical because of data
> loss.
> Further testing desired and possible backport of fix to 4.4 and 4.3.

There's going to need to be a lot more specifics provided before the developers will want to look at this/these issue(s).

Given that the original report seems to be unconfirmed (no error on save reproduced), I'm marking this as RESOLVED WORKSFORME, and suggest that you (Stefan or Timur) file any new bugs against this test file as needed to cover all of the problems listed above.

Stefan: If you're still having the specific problem of an error when saving, feel free to change status back to UNCONFIRMED. Thanks!
Comment 10 Timur 2015-03-06 09:23:27 UTC
(In reply to Robinson Tryon (qubit) from comment #9)
> Given that the original report seems to be unconfirmed (no error on save
> reproduced), I'm marking this as RESOLVED WORKSFORME, and suggest that you
> (Stefan or Timur) file any new bugs against this test file as needed to
> cover all of the problems listed above.
I did that in Bug 89858 - Filesave as DOCX looses text, 3 of 7 pages saved.
I revert status of this bug to the original values, except WFM.