Download it now!
Bug 77430 - EDITING: Text and other Objects inserted in Charts go completely lost
Summary: EDITING: Text and other Objects inserted in Charts go completely lost
Status: RESOLVED DUPLICATE of bug 74333
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: Other Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-04-14 11:12 UTC by Andy
Modified: 2015-12-15 10:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy 2014-04-14 11:12:09 UTC
Problem description: Then  

Steps to reproduce:
1. Open a spreadsheet, type a few numbers and create a chart with them. 
2. Create and add a personalized text object in the chart, e.g. a description or any other comment you want to show somewhere in the chart and is not an automatic chart object like title or axis label. Alternatively, insert a graphic object like a rectangle.
3. Save the file and reopen it: the text or other object object is lost, and there seems to be no way to recover it.

Current behavior: This happens also when you open a file created with a previous version: I had a paper with 50 charts inserted, edited with no problem until 4.1.5, all with description inserted as text objects, now I open it with 4.2.2.1 and ALL of them are lost. All charts are shown, but none of them has the inserted text objects anymore.
Expected behavior: All objects inserted in a chart to personalize it should be saved as before.
To avoid MASSIVE DATA LOSS I now cannot edit the file anymore.

              
Operating System: Windows 7
Version: 4.2.2.1 release
Last worked in: 4.1.5.3 release
Comment 1 Andy 2014-04-14 11:16:44 UTC
I raised the importance of the bug since on all documents created with previous versions with this kind of data, this prevents ANY further editing, unless you accept to suffer a potentially huge data loss.
Comment 2 m.a.riosv 2014-04-15 23:52:41 UTC

*** This bug has been marked as a duplicate of bug 74333 ***
Comment 3 Robinson Tryon (qubit) 2015-12-15 10:54:56 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]