Bug 77464 - BUGZILLAASSISTANT: Bugzilla Submission Assistant does not support more than one bug submission
Summary: BUGZILLAASSISTANT: Bugzilla Submission Assistant does not support more than o...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 57906 76433 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-04-15 04:49 UTC by abq911
Modified: 2014-04-28 14:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Uncaught exception found in the Javascript console (988 bytes, text/plain)
2014-04-15 04:52 UTC, abq911
Details

Note You need to log in before you can comment on or make changes to this bug.
Description abq911 2014-04-15 04:49:27 UTC
Problem description: Title self-explanatory, very frustrating because error is very obtuse and causes an uncaught exception.

Steps to reproduce:
1. Open Bug Submission Assistant at https://www.libreoffice.org/get-help/bug/
2. Submit a bug
3. Open the page again and attempt to submit another bug

Current behavior: Error message displayed: "It looks like you didn't come from the right page (you have no valid token for the "

Expected behavior: Should be able to submit multiple bugs through the simpler interface.

              
Operating System: All
Version: 4.2.2.1 release
Comment 1 abq911 2014-04-15 04:52:20 UTC
Created attachment 97375 [details]
Uncaught exception found in the Javascript console
Comment 2 Christian Lohmaier 2014-04-28 14:04:17 UTC
Ah, that's a description that explains all those problems people have with the BSA - and lets me fix it.

All requests were delivered with a expires of a two weeks by default, as for what it concerns the webserver it is a static file - but it hooks into bugzilla that must re-requeste everytime.

Changed the config to not add expires header - so should work now.
Comment 3 Christian Lohmaier 2014-04-28 14:20:42 UTC
*** Bug 57906 has been marked as a duplicate of this bug. ***
Comment 4 Christian Lohmaier 2014-04-28 14:30:19 UTC
*** Bug 76433 has been marked as a duplicate of this bug. ***