Bug Hunting Session
Bug 77498 - Chart legend information is lost when the chart is copied + pasted
Summary: Chart legend information is lost when the chart is copied + pasted
Status: RESOLVED DUPLICATE of bug 77506
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-15 19:39 UTC by Anonymous Helper
Modified: 2015-01-24 14:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
LO calc file with the correct chart. (31.07 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-04-15 19:39 UTC, Anonymous Helper
Details
LO writer document with wrong chart. (27.44 KB, application/vnd.oasis.opendocument.text)
2014-04-15 19:40 UTC, Anonymous Helper
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anonymous Helper 2014-04-15 19:39:04 UTC
Created attachment 97425 [details]
LO calc file with the correct chart.

Hello,
I think I found a bug in Libreoffice, but I don't know if only Linux is affected and also don't know since when (which version).
I use Libreoffice on Fedora Linux with Build-ID: 4.2.3.3-1.fc20. It is affected as long as I can remenber.

The problem is the following:
I create a chart in Libreoffice Calc with some data and everything is fine. Now I copy the chart (ctrl-c) and insert it in a Libreoffice Writer document (ctrl-v) and now the legend is not correct anymore. Plase take a look at those files.
If you copy the copy again the error becomes worse.
I also found out, that there is no need to change anything in the LO writer document. If you save the file (no change regarding the cart), the chart legend becomes worse (it "moves" one step everytime you save or copy-paste).

Plase take a look at those files and tell my if you need more information.
Thanks in advance!
Comment 1 Anonymous Helper 2014-04-15 19:40:11 UTC
Created attachment 97426 [details]
LO writer document with wrong chart.
Comment 2 Anonymous Helper 2014-04-22 17:38:29 UTC
Just wanted to show a workaround for other affected personens: If you special-paste the chart with Shift-Ctrl-V and selecting GDI metafile it works.
This bug is still not fixed, though.
Comment 3 sophie 2014-04-23 15:19:51 UTC
Hi, confirmed using 4.2.4.1 Ubuntu 14.04 - Set first version and New - Sophie
Comment 4 Jan Husarik 2014-05-07 04:38:59 UTC
Have the same issue Windows and Mac OS. Copy paste does generally a lot of bad things to the graphs, sometimes even duplicating columns and adding empty columns as well. I could not figure out under witch circumstances this happens though.

As for the special copy paste method, it works but it is very ugly workaround and would prefer not to use it (since the graph itself is no longer editable)
Comment 5 Kohei Yoshida 2014-06-20 03:42:13 UTC

*** This bug has been marked as a duplicate of bug 77506 ***