Bug 77517 - COLUMN, ROW functions with reference to external file result in Err:504
Summary: COLUMN, ROW functions with reference to external file result in Err:504
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.4.1 rc
Hardware: All All
: high major
Assignee: Winfried Donkers (retired)
URL:
Whiteboard: target:6.2.0 target:6.1.0.1
Keywords:
Depends on:
Blocks: Calc-Function
  Show dependency treegraph
 
Reported: 2014-04-16 09:27 UTC by juergensohn
Modified: 2018-06-21 09:32 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description juergensohn 2014-04-16 09:27:03 UTC
I use a german Version of LibreOffice scalc 4.2.2.1 Windows 7.
I changed recently from OpenOffice 3.0.1
I've got an error 504 when I try
=ZEILE('file:///C:/temp/Unbenannt.ods'#$Tabelle1.A2) ("Zeile" means "ROW")
or
=ISTBEZUG('file:///C:/temp/Unbenannt.ods'#$Tabelle1.A2) ("ISTBEZUG" means "ISREF")

in OO 3.0.1 these examples work
Comment 1 m.a.riosv 2014-04-19 02:17:26 UTC
Hi Juergen, thanks for reporting.

I can reproduce the issue for ROW() functions with:
Win7x64Ultimate
Version: 4.2.2.1 Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f
Version: 4.2.5.0.0+ Build ID: cc45204a7a286cef32fc7faf266dc2da235c1ae2
   TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-04-17_02:46:49
Version: 4.3.0.0.alpha0+ Build ID: 0ce6d9bcea7c37a7cb2c42e8393e2e20780bd171
   TinderBox: Win-x86@39, Branch:master, Time: 2014-04-17_00:11:33

but not for the ISREF() function.
Comment 2 juergensohn 2014-04-21 21:54:39 UTC
Hi,
does this mean, that you get an error for

ROW('file:///C:/temp/Unbenannt.ods'#$Tabelle1.A2)
but not for
isref('file:///C:/temp/Unbenannt.ods'#$Tabelle1.A2)


Am 19.04.2014 04:17, schrieb bugzilla-daemon@freedesktop.org:
> m.a.riosv <mailto:mariosv@miguelangel.mobi> changed bug 77517 
> <https://bugs.freedesktop.org/show_bug.cgi?id=77517>
> What 	Removed 	Added
> Status 	UNCONFIRMED 	NEW
> CC 		mariosv@miguelangel.mobi
> Ever confirmed 		1
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=77517#c1> 
> on bug 77517 <https://bugs.freedesktop.org/show_bug.cgi?id=77517> from 
> m.a.riosv <mailto:mariosv@miguelangel.mobi> *
> Hi Juergen, thanks for reporting.
>
> I can reproduce the issue for ROW() functions with:
> Win7x64Ultimate
> Version: 4.2.2.1 Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f
> Version: 4.2.5.0.0+ Build ID: cc45204a7a286cef32fc7faf266dc2da235c1ae2
>     TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-04-17_02:46:49
> Version: 4.3.0.0.alpha0+ Build ID: 0ce6d9bcea7c37a7cb2c42e8393e2e20780bd171
>     TinderBox: Win-x86@39, Branch:master, Time: 2014-04-17_00:11:33
>
> but not for the ISREF() function.
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>



---
Diese E-Mail ist frei von Viren und Malware, denn der avast! Antivirus Schutz ist aktiv.
http://www.avast.com
Comment 3 m.a.riosv 2014-04-21 22:48:47 UTC
Yes.

(Please if you can answer here, or if you answer from your client email program try to avoid reproduce the text)
Comment 4 Joel Madero 2015-05-12 17:23:54 UTC
This is not a critical bug - as we can see - not a lot of dupes, not a lot of users commenting. There is apparently loss of data but it's very specific to external references on Windows platform. 

It would be nice to know if:

1) This is still a problem with 4.4.3 or newer;

2) Did this ever work correctly? (Please test 3.3 and report back)

http://downloadarchive.documentfoundation.org/libreoffice/old/
Comment 5 QA Administrators 2016-09-20 09:42:44 UTC Comment hidden (obsolete)
Comment 6 m.a.riosv 2016-09-21 22:35:12 UTC
Still there at least for ROW()
Win10x64
Version: 5.2.2.1 (x64)
Build ID: 3c2231d4aa4c68281f28ad35a100c092cff84f5d
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: es-ES (es_ES); Calc: group
Comment 7 Xisco Faulí 2017-09-29 08:50:34 UTC Comment hidden (obsolete)
Comment 8 Xisco Faulí 2018-05-08 09:44:36 UTC
Dear Bartosz,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 9 Xisco Faulí 2018-06-07 10:03:00 UTC
@Eike, @Winfried, i thought you could be interested in this issue...
Comment 10 Eike Rathke 2018-06-07 16:40:54 UTC
@Winfried: one for you?

svExternalSingleRef and svExternalDoubleRef aren't handled in ScInterpreter::ScRow() and ScInterpreter::ScColumn(). Should not be too complicated, obtain the external references as in ScInterpreter::ScOffset() and for svExternalDoubleRef use the calculation of svDoubleRef that creates a matrix.
Comment 11 Winfried Donkers (retired) 2018-06-11 05:53:37 UTC
(In reply to Eike Rathke from comment #10)
> @Winfried: one for you?
> 
> svExternalSingleRef and svExternalDoubleRef aren't handled in
> ScInterpreter::ScRow() and ScInterpreter::ScColumn(). Should not be too
> complicated, obtain the external references as in ScInterpreter::ScOffset()
> and for svExternalDoubleRef use the calculation of svDoubleRef that creates
> a matrix.

Thanks for the pointers ;-)
I'll work on it (once I have finished the bug I'm currently working on).
Comment 12 Commit Notification 2018-06-15 08:42:51 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b1740fba0d1e6e3d69c3781734509317f42a0e4f

tdf#77517 make Calc function ROW accept external references.

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2018-06-19 22:19:30 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=28f3e44e99283ede636c28c68bffb2b9df0bbcf8

tdf#77517 make Calc function COLUMN accept external references.

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2018-06-19 23:39:54 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d5c8199a94d0e2f722fff6637b930205a6641adf&h=libreoffice-6-1

tdf#77517 make Calc function COLUMN accept external references.

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2018-06-20 11:42:17 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ad6bdc81f3b47cc46a7751e93e59fb92edd28baf&h=libreoffice-6-1

tdf#77517 make Calc function ROW accept external references.

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2018-06-20 18:09:32 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3613990eaae645e0489660be2dab8a61cab8a69c

tdf#77517 Additions to unit tests.

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.