Bug 77519 - EDITING: chapter entry as number in any Index becomes <??>
Summary: EDITING: chapter entry as number in any Index becomes <??>
Status: RESOLVED DUPLICATE of bug 75519
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-04-16 09:50 UTC by chris.hoe
Modified: 2014-05-07 13:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots showing the effect of the described bug. (317.27 KB, application/vnd.oasis.opendocument.graphics)
2014-04-16 09:50 UTC, chris.hoe
Details
reduced version of the manual where I noticed the bug first (2.33 MB, application/vnd.oasis.opendocument.text)
2014-04-22 11:46 UTC, chris.hoe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description chris.hoe 2014-04-16 09:50:12 UTC
Created attachment 97465 [details]
Screenshots showing the effect of the described bug.

I have an "Illustration Index" in one of the bigger documents I created with LO. After upgrading to LO 4.2.x the chapter reference in this index changes to ?? when I'm updating the index. Doing the same with a 4.0.x or 4.1.x version works OK. I've checked the bug with 4.2.2 release and 4.2.3 release on a 64bit Win7 and a 32bit WinXP - same behaviour. A "User-Defined Index" inserted for testing shows the same behaviour. I attach a screen-shot which shows my index before and after an update with LO 4.2.x.

In fact, the bug seems to be somehow related to [75519] - it is about chapter cross-reference and the result is ??. In addition, if I add a "User-Defined Index" to the sample doc from [75519], it shows the same ?? as chapter references. Probably it is duplicate but I'm not sure - therefore I file it separately.

As this bug renders any index with chapter reference useless, I would like to have this bug a higher priority than the <medium>/<normal> in [75519] - especially as it was newly introduced in 4.2.x and worked OK with 4.1.x and older (didn't check 3.x releases, though).
Comment 1 Jorendc 2014-04-18 21:07:25 UTC
Thanks for your research and feedback.

I read your comment on bug 75519 (you can reproduce that bug), but is it possible to attach a small portion of your document, which still reproduce the behavior. Feel free to sensor the content first (hint: search and replace can change some characters in batch to 'x' or something like that).

Kind regards,
Joren
Comment 2 chris.hoe 2014-04-22 11:44:38 UTC
Hi Joren,

thanks for your reply. Yes, I can shrink my document a bit still reproducing the bug. The content is not a secret - its a published manual anyway.
I attach this version in which I threw out a lot of text but keeping the chapter structure and a few figures per chapter (1..3). I didn't updated neither the contents index nor the figures index - that's why the indexes are looking ok when you open the document. If you do an update of the figures index (at the end of the document) with a 4.2.x release, you'll get the ?? instead of chapter numbers. If you do the same with the contents index, the chapter numbers are ok.
I hope that's the kind of document you have asked for - if not feel free to contact me again. It's really crucial for to get this bug fixed as it renders my document useless - that means that I have to stick with LO 4.1.x until it gets fixed.

Best regards, Christian
Comment 3 chris.hoe 2014-04-22 11:46:16 UTC
Created attachment 97742 [details]
reduced version of the manual where I noticed the bug first
Comment 4 chris.hoe 2014-04-23 14:28:03 UTC
Just to reconfirm - 4.2.4rc1 still has this problem.
Comment 5 Jorendc 2014-04-30 17:57:06 UTC
Thanks for your extra information!

Reproducible, tested using windows 8.1 using LibreOffice Version: 4.3.0.0.alpha1+
Build ID: 0b03f7ed575838f90e6b1ebec3538a3a214f81fb
TinderBox: Win-x86@39, Branch:master, Time: 2014-04-30_01:30:46

* Open attached test document
* scroll to one of the last pages of the document
* Right click > update Index/table

Kind regards,
Joren
Comment 6 chris.hoe 2014-05-05 19:17:42 UTC
Thanks Joren for confirming. Does anybody work on that item? I just tested 4.2.4rc2 and it still has the problem.

Kind regards, Christian
Comment 7 Michael Stahl (CIB) 2014-05-07 13:23:41 UTC

*** This bug has been marked as a duplicate of bug 75519 ***