Download it now!
Bug 77530 - FILESAVE: saving a new file
Summary: FILESAVE: saving a new file
Status: RESOLVED DUPLICATE of bug 69002
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-16 14:21 UTC by thejunk.b
Modified: 2014-04-25 11:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
libreoffice calc crash log (23.69 KB, text/x-log)
2014-04-18 13:47 UTC, thejunk.b
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thejunk.b 2014-04-16 14:21:16 UTC
Problem description: When trying to save a new spreadsheet Libreoffice crashes

Steps to reproduce:
1. open new spreadsheet
2. add data, or not
3. save or save-as
4. crash

Current behavior: this only happens after the first time you save a new file.  An existing file is not affected.  I first noticed this one maybe 2-3 versions ago (versions from Debian Jessie (testing)) when copying groups of cells out of an existing spreadsheet to a new one then trying to save it, which resulted in a crash.  If the new file was saved first the crash did not happen.  But now I can only save the new file once after a computer restart. Trying to save a second new file results in crash.

The system is Debian64 Jessie (testing) patched weekly, with KDE. Libreoffice reports that it is 
Version: 4.1.5.3
Build ID: 410m0(Build:3)
and was installed out of the Debian Repos.

Expected behavior:
To be able to save a new file.
              
Operating System: Debian
Version: 4.1.5.3 release
Comment 1 Julien Nabet 2014-04-16 20:17:04 UTC
Did you install any LO specific extensions?
For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile) and give it a new try?
Comment 2 thejunk.b 2014-04-16 21:13:13 UTC
Thanks,

The installed libreoffice packages from the debian repos:
libreoffice
libreoffice-base
libreoffice-base-core
libreoffice-calc
libreoffice-common
libreoffice-core
libreoffice-draw
libreoffice-emailmerge
libreoffice-filter-binfilter
libreoffice-help-en-us
libreoffice-impress
libreoffice-java-common
libreoffice-kde
libreoffice-math
libreoffice-mysql-connector
libreoffice-pdfimport
libreoffice-report-builder-bin
libreoffice-style-galaxy
libreoffice-style-oxygen
libreoffice-writer

The only extension I have installed is the mysql-connector.  And I only install software from repos.

I renamed my user folder and restarted, same results.

I do have another issue, probably not related but, libreoffice among other apps do not recognize that the default printer has been changed.  KDE and Cups both register it as one printer but when I go to print the old default printer is selected.  Not sure it has any bearing but who knows.
Comment 3 thejunk.b 2014-04-17 01:03:17 UTC
Sorry to have wasted your time.  I wish I had thought to do some testing on another machine before I filed the report.

Anyway I purged libreoffice and re-installed and the problem seams to have gone away.

Once again sorry.
Comment 4 Julien Nabet 2014-04-17 05:26:08 UTC
Thank you for your feedback, let's put this this tracker to WFM.
Comment 5 thejunk.b 2014-04-17 21:45:08 UTC
Ahhhhhhhh

I lied.

It did to me again.

I had made a file-1 and opened it for editing

Opened a second existing template and copied a sheet out of it into file-1

Did some heavy editing and data entry saving the file all through the process

Closed the template after the copy so it was long closed

Using the menu > file > new > spreadsheet I opened a new file-2

I did not immediately save it ( has worked in the past to get around the issue)

Did some data entry on file-2 and formating, no formulas. It is just a blank form.

I did try to copy/paste some data out of Okular (pdf) but they have managed to break it again :{ I can't select any text with it, at least from that pdf file.

finished making the form (file-2) and went to save it, file-1 was still open, and crash.

in the past if the new unsaved file had data in it when the recovery thingy reopened it the data was gone.  This time the data was still there.  After both files were recovered I first saved and closed file-1, in the past that has made saving the second file successful.  Then I did manage to save file-2.

Also in the past the save dialog box has come up but when trying to select a different directory it would crash.

I have tried to attached file-2 but somehow it didn't work
Comment 6 thejunk.b 2014-04-17 23:03:07 UTC
And again, this time I reopened file-1 did some further editing, added a few lines, inserted and removed various lines, saved the file, came back to it some time later formated sheet 1 of 3 for export to pdf.

Exported the sheet by selecting the area I wanted in the pdf.  Did not like the results, page breaks not in the right spot.  Did some further editing to correct the page breaks.  Selected the area again. From the menu > file > export as pdf = crash.

I did discover that again I had 2 files open when the crash occurred.  Maybe that is the key.

I had used print-preview in the formatting process.

It crashed when I tried to select the previous pdf file name for saving the redo.

So again after the recovery the export worked as expected.
Comment 7 thejunk.b 2014-04-17 23:13:37 UTC
Re opening file-2 with file-1 still open, exporting file-2 as pdf, adding some lines to get the page breaks in the right places, re-exporting, selecting the previous pdf file name did not result in a crash.
Comment 8 Julien Nabet 2014-04-18 05:27:08 UTC
Could you try to retrieve a backtrace by following this link https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace ?
Comment 9 thejunk.b 2014-04-18 13:47:09 UTC
Created attachment 97560 [details]
libreoffice calc crash log
Comment 10 thejunk.b 2014-04-18 13:48:04 UTC
From the console at crash time

$ soffice --backtrace
GNU gdb (GDB) 7.6.2 (Debian 7.6.2-1)
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/lib/libreoffice/program/soffice.bin...(no debugging symbols found)...done.
log will be saved as gdbtrace.log, this will take some time, patience...
Object::connect: No such signal org::freedesktop::UPower::DeviceAdded(QDBusObjectPath)
Object::connect: No such signal org::freedesktop::UPower::DeviceRemoved(QDBusObjectPath)
"/org/freedesktop/UDisks2/drives/ST9500420AS_5VJ5NLNT" : property "Drive" does not exist 
"/org/freedesktop/UDisks2/drives/TEAC_DVD_ROM_DV18SA_10051621092906" : property "Drive" does not exist 
"/org/freedesktop/UDisks2/drives/ST9500420AS_5VJ5NLNT" : property "DeviceNumber" does not exist 
"/org/freedesktop/UDisks2/drives/ST9500420AS_5VJ5NLNT" : property "Device" does not exist 
:~$

Don't know if it helps
Comment 11 thejunk.b 2014-04-18 13:52:03 UTC
Oh yea, I forgot

In the process of installing libreoffice-dbg I also updated the system with a few patches.  One of them was libreoffice.  So now I am on

Version: 4.1.5.3
Build ID: 410m0(Build:3)
Comment 12 Julien Nabet 2014-04-18 21:47:21 UTC
Do you use local hard disk or other like network drivers for example?

Anyway, I put it at NEW since there's a bt.

Lunos/Stephan: Seems KDE related according to bt, one for you?
Comment 13 thejunk.b 2014-04-18 22:18:35 UTC
local encrypted drive.
500 gig
Partition layout
sda1 boot partition
sda2 extended /w sda5 luks crypt /w /, /home, /swap
sda3 manually mounted storage (almost never mounted)
Comment 14 Luboš Luňák 2014-04-25 11:28:01 UTC
This should get fixed with my latest fix for Qt event loop integration.

*** This bug has been marked as a duplicate of bug 69002 ***