Bug 77563 - FILEOPEN: different behavior for new file using a default font
Summary: FILEOPEN: different behavior for new file using a default font
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-17 08:54 UTC by Benjamin Bartsch
Modified: 2014-06-10 12:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Bartsch 2014-04-17 08:54:19 UTC
different behavior for new file using a default font

Problem description: 

If I change under 

German: Extras - Optionen - LibreOffice Writer - Grundschriftarten 
?English: Extras - Options - LibreOffice Writer - Default Fonts

the generell font for all (five) categories to "Linux Biolium G" then this will have an affect only if I open a new Writer document in a specific manner (see below).

Steps to reproduce:
WORKING: Opening a new document using a link will open LibreOffice with the Font "Linux Biolium".
NOT WORKING: Opening a new document using a rightclick on the Desktop and then choosing "new --> OpenDocument Text" will create a new document. Doubleclicking on this new document opens an empty document but with font "times new roman".

Current behavior:
---

Expected behavior:
Since I changed the Default Font. I would except that opening a new (empty) document IN ANY WAY should always give me an empty document with the previously configured default font.

Benjamin Bartsch
Operating System: Windows XP
Version: 4.2.2.1 release
Comment 1 Yousuf Philips (jay) (retired) 2014-06-07 01:53:41 UTC
I doubt this will be fixed as when you right-click and select a new template to begin with, it simply copies an existing document file to that location and allows you to rename it. It is not possible to insert your currently set default fonts into such a file at that given moment, unless whenever you change the default fonts, those existing document files are overwritten.

Joel: am i right to think this?
Comment 2 pierre-yves samyn 2014-06-10 12:34:01 UTC
Hi

(In reply to comment #1)
> I doubt this will be fixed as when you right-click and select a new template
> to begin with, it simply copies an existing document file to that location
> and allows you to rename it. It is not possible to insert your currently set
> default fonts into such a file at that given moment, unless whenever you
> change the default fonts, those existing document files are overwritten.
> 
> Joel: am i right to think this?

Yes: The system performs only a copy of a template document. This explains why creation is so fast and does not require opening software.

Simply modify or replace this template document.

Depending on your version of windows and your choice of installation (installation for you alone or for all users) the path to the document could be:

C:\Documents and Settings\All Users\Templates (XP)
C:\Documents and Settings\username\Templates (XP)
C:\ProgramData\Microsoft\Windows\Templates (Windows 7)
C:\Program Files (x86)\LibreOffice 4\share\template\shellnew
etc.

Note: you will need to have administrator rights to modify this document (Windows7)

Regards
Pierre-Yves