Bug 77569 - Add entry "Choose Themes" to menu "Format" to actually make Calc feature accessible to users
Summary: Add entry "Choose Themes" to menu "Format" to actually make Calc feature acce...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: All All
: medium enhancement
Assignee: Yousuf Philips (jay)
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Menus Document-Themes Calc-Styles
  Show dependency treegraph
 
Reported: 2014-04-17 10:35 UTC by Gerry
Modified: 2017-05-19 21:16 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Example .ods for choose themes (10.80 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-11-07 10:57 UTC, Gerry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2014-04-17 10:35:36 UTC
With "Choose Themes", Calc in fact has a very neat feature which is barely accessible to the user. This could be easily changed by simiply adding "Choose Themes" to the entries of the menu "Format".

More information:
Calc provides a very nice feature which is comparable to Table Styles ("Format as Table" in Excel). However, this feature is barely accessible for users.
To use it, the user has to activate "View" -> "Toolbars" -> "Tools". Then, the user can click on the button "Choose Themes" and enjoys this great feature.

Solution:
Please add "Choose themes" to the menu "Format". This simple addition would make this feature more accessible to users.

This is a trivial enhancement request and probably is a very easy hack.
Comment 1 Joel Madero 2014-05-19 15:30:04 UTC
Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.3.0.0.alpha0+ Build ID: 84862db95a5e22b9ef89baa2a8a5deeffefbdef6
Date:   Thu Apr 24 21:43:16 2014 +0300
Platform: Ubuntu Linux 14.04 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
Medium - because it seems to be an easy hack, and most the code is already available, medium seems appropriate.


I'll see what I can do.
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Joel Madero 2014-11-06 04:01:34 UTC
Patch committed into 4.4 branch. Awaiting confirmation then will close this as FIXED.
Comment 3 Samuel Mehrbrodt (CIB) 2014-11-06 18:10:08 UTC
Is there a way to edit these themes or create new ones?
Comment 4 Joel Madero 2014-11-06 18:11:39 UTC
No idea - I had never used them before ;) Probably go ask on the ask site or user mailing list :)
Comment 5 Samuel Mehrbrodt (CIB) 2014-11-06 18:27:20 UTC
I don't really get the sense of this themes thing - all it does for me is change the background.
If we want this in the main menu, we need to make sure that users understand what this is for.
Comment 6 Joel Madero 2014-11-06 18:31:21 UTC
I was also a little confused as to what it does....but because a user requested I committed, if it's discarded, I won't protest and it can be closed as WONTFIX ;)
Comment 7 Olivier Hallot 2014-11-06 19:24:34 UTC
Thanks for the patch

Actually these themes adds many cell styles to the spreadsheet. Hit F11 and you'll see many cell styles to assist you to build a nice table. (Hint: T = top, B= bottom, BL=bottom left, etc...)
Comment 8 Joel Madero 2014-11-06 19:30:00 UTC
Yeah - but the Themes thing is different and seems to just change the entire page....which seems wrong :-/
Comment 9 Olivier Hallot 2014-11-06 19:32:20 UTC
On another look, if your Calc table / spreadsheet has all these "Card-*" cell styles applied, you can change its look by just changing the theme.

Admitedly, we should complete this features providing a Calc template that includes a set of cells (forming a table) with these styles applied. There is, nevertheless, a redundancy WRT Table AutoFormat
Comment 10 Gerry 2014-11-06 20:22:08 UTC
Hi, 

the "Choose themes" approach seems to be much more consistent with LibreOffice's reliance on styles as compared to the AutoFormat approach. Hence, in my opinion, the "Choose themes" approach is superior. However, I agree that ultimately "Choose Themes" needs to be improved/completed to be competitive with other spreadsheet software. On the other hand, it seems to be the best that LO currently has with regards to "Table Styles".
Comment 11 Gerry 2014-11-07 09:12:53 UTC
Some more notes on "Choose Themes". Generally, I suggest that you to play a bit with it and see how capable this feature is. In fact, it is very powerful and IMHO the only real counterpart to Excel's "Table Styles". However, it is currently hidden in an optional toolbar. 

"Choose Themes" creates a bunch of cell styles that are aligned with the chosen theme. This includes: all font settings (color, alignment, size, font type), background, borders and so forth. The procedure is to choose a theme and then assign the theme-related cell styles from the "Styles and Formatting" window.

Advantages of "ChooseThemes" over "AutoFormat":
* "Choose Themes" nicely integrates with the styles concept of LibreOffice
* Results are much more beautiful (and less 1990s) than with "AutoFormat"
* It is possible to fine-tune/change the cell styles of a theme by using "modify cell style".
* "Choose Themes" is more powerful if the theme/style of all tables need to be changed. This is done with just one click by assigning a different theme. "AutoFormat" is very cumbersome in this regard, as "AutoFormat" just formats the current selection; the chosen AutoFormat is nowhere saved or stored. Hence, AutoFormat is just for non-systematic ad-hoc formatting of single tables.
* "ChooseThemes" chooses the theme for the entire workbook, but the cell style assignment works on basis of the selected cell range. This is very flexible.

Disadvantages of "ChooseThemes" compared to "AutoFormat":
* With "Choose Themes" it is not (easily) possible to create a new theme out of the current cell selection. There is no button like "Add Theme" or something similar.
* "Choose Themes" doesn't set the entire table (with row headings, column headings) with one click like it is with "AutoFormat", but the user needs to choose the cell styles for the headings from available cell styles.
* "Choose Themes" does not set "AutoFit width and height" of cells, which AutoFormat does. (but I doubt whether this is actually useful)

Improvements to "ChooseThemes" to make it "perfect" in the long run:
* Add the ability to add themes on basis of current cell selection
* Add the ability to format on table-level (assigning different cell styles for row/column headings or footer, and content cells).
* Make it easier for the user to understand that there are two steps: Step1: assign theme, step2: assign theme-related cell styles.

My suggestion is to make both, "AutoFormat" and "ChooseThemes" accessible from the main menu (like stated in this bug report). They do duplicate some functionality, but they are very different in concept and design. Choose Themes is conceptually superior and - in the long run - , I think, it is the way to go, if missing features are integrated and user friendliness improved.
Comment 12 Gerry 2014-11-07 10:57:48 UTC
Created attachment 109080 [details]
Example .ods for choose themes

(1) I opened a separate bug 85998 for enhancements to the "Choose Themes" feature.
(2) Please find a sample Calc sheet attached which has defined themes. When you click on "Choose Themes" you can browse through the different themes and see how they change the look of the sheet and tables.
(3) "ChooseThemes" is currently not capable to define alternating rows (see bug 85998)
Comment 13 Samuel Mehrbrodt (CIB) 2014-11-07 11:30:00 UTC
(In reply to Gerry from comment #12)
> Created attachment 109080 [details]

Thanks for this file.

I had a quick look at the code, and that dialog is written in Basic and has a hard-coded list of themes.

I guess if we want to improve this, it probably needs a rewrite in C++.
From there we can start and add enhancements.
So I would suggest to close this as WONTFIX until someone implements a proper theme system for calc.

I wouldn't add it to the main menu as it is because it lacks the most basic features (like editing and adding/removing themes).
Comment 14 Gerry 2014-11-07 14:28:24 UTC
@Samuel: Can you please open a new bug with your enhancement request to the theming system for Calc. In your bug report, please refer to bug 85998 (or include those enhancement requests in your bug so that you can close 85998, too)

Then, I am fine to close this as WONTFIX.
Comment 15 Yousuf Philips (jay) 2017-05-19 21:16:39 UTC
Patch is in - https://gerrit.libreoffice.org/37844