Download it now!
Bug 77593 - asterisk key "*" interpreted as a wildcard in autocorrect replacement table
Summary: asterisk key "*" interpreted as a wildcard in autocorrect replacement table
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
4.2.0.1 rc
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-04-17 20:46 UTC by tommy27
Modified: 2015-02-12 11:50 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
autocorrect database (11.82 KB, application/zip)
2014-04-17 20:46 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tommy27 2014-04-17 20:46:00 UTC
Created attachment 97535 [details]
autocorrect database

this is a followup of Bug 77508	where this weird autocorrect regression bug was initially reported and confirmed by other Windows users

STEPS TO REPRODUCE

- download the attached acor_und.dat file
- place it in LibO user profile under the "autocorr" subfolder
- open a Writer new document
- type 8 followed by space or any other typing character (i.e. 8, 8a, 81, 8!)
- you will see weird automatic corrections (i.e 8°, 8°a, 8°1, 8°!)

RATIONALE

basically in LibO 4.2.x the asterisk key is now interpreted as a wilcard in autocorrect replacement table unlike 4.1.x where it was interpreted as a normal typing character

this results in unwanted weird autocorrections in 4.2.x

so, if you had a 4.1.x autocorrect entry like:

8* --> 8°  (which is contained in the acor_und.dat file and can be shown in autocorrect replacement table in "Tools/AutoCorrect options/Replace")

the autocorrect will correctly change 8* to 8°

if you have the same 8* --> 8° entry in 4.2.x now it will change any typing combination involving 8 and any other following typing characters.

i.e.
8 [space] --> 8°
8a --> 8°a
81 --> 8°1
8) --> 8°)
8° --> 8°°

and so on....


so, any autocorrect entry inherited from 4.1.x in which an asterisk key is present, will result in unwanted and impredictable autocorrections in 4.2.x.

IMHO the autocorrect engine should not use wildcards because it breaks compatibility with previous autocorrect database and because wildcards may result, as in this case, in unwanted and impredictable autocorrections.
Comment 1 Andras Timar 2014-04-17 21:05:15 UTC
See bug 68373.
Comment 2 Joel Madero 2014-04-17 21:09:32 UTC
This isn't a bug - it was done on purpose (see comment put by Andras)
Comment 3 tommy27 2014-04-17 21:17:56 UTC
ok. I see. It had some nasty side effects on my side and drove me crazy to figure out what happened. now that I know what's wrong I will cope with it and remove those "asterisks" in my autocorrect database to avoid unwanted interferences.

thank you everybody and sorry for the noise :-)

anyway what about adding info about this new feature in 4.2 release notes?
people who's unaware of this change and uses old autocorrect databases with asterisks now turning into wildcars could experience the same troubles I did.
Comment 4 Joel Madero 2014-04-17 21:18:50 UTC
+1 - not sure who to ping about that...maybe www list?