Download it now!
Bug 77597 - FILESAVE: [regression] rtf file opens with half of all pages missing
Summary: FILESAVE: [regression] rtf file opens with half of all pages missing
Status: RESOLVED DUPLICATE of bug 76633
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:rtf, regression
Depends on:
Blocks: RTF Shapes
  Show dependency treegraph
 
Reported: 2014-04-17 22:45 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-09-29 12:06 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
shows half the left half of the page as missing (35.92 KB, image/jpeg)
2014-04-17 22:45 UTC, Yousuf Philips (jay) (retired)
Details
hidden object in the top left corner of document (751.67 KB, image/png)
2014-04-22 21:40 UTC, Yousuf Philips (jay) (retired)
Details
right-clicking on the object (719.90 KB, image/png)
2014-04-22 21:41 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-04-17 22:45:14 UTC
Created attachment 97547 [details]
shows half the left half of the page as missing

I opened the docx file at < http://www.microsoft.com/investor/reports/ar13/docs/2013_Annual_Report.docx > and then saved it as an rtf. then i opened the rtf file and the left half of all pages are missing. I can still select the text that appears on the page, but something is causing it to be invisible.
Comment 1 Yousuf Philips (jay) (retired) 2014-04-17 22:47:13 UTC
This regression effects versions of 4.2 and 4.1
Comment 2 Michael Meeks 2014-04-19 19:10:09 UTC
A similar RTF issue =)
Comment 3 Robinson Tryon (qubit) 2014-04-20 22:39:27 UTC
(In reply to comment #0)
> I opened the docx file at <
> http://www.microsoft.com/investor/reports/ar13/docs/2013_Annual_Report.docx
> > and then saved it as an rtf. then i opened the rtf file and the left half
> of all pages are missing. I can still select the text that appears on the
> page, but something is causing it to be invisible.

CONFIRMED on Ubuntu 12.04.4 + LO 4.2.3.3
Status -> NEW

Interestingly, the pages appear correct initially (perhaps as the 300+ pages are still loading), and then after a while the pages appear to repaint and the left side of all of the pages (including the first-page graphic) is invisible. If I open up File -> Page Preview and then close it, the pages (temporarily) return to full visibility.
Comment 4 Robinson Tryon (qubit) 2014-04-20 22:40:53 UTC
Jay - You mentioned that this a regression. Which versions of LibreOffice display the RTF file correctly?
Comment 5 Jorendc 2014-04-21 09:14:08 UTC
Also reproducible, tested using Mac OSX 10.9 with LibreOffice Version: 4.3.0.0.alpha0+ Build ID: 619b4c40da9e85febbb08a3f7cf8aa8d10963fc1
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-04-18_00:07:53

Same behavior as Qubit

Kind regards,
Joren
Comment 6 Yousuf Philips (jay) (retired) 2014-04-22 02:05:11 UTC
(In reply to comment #4)
> Jay - You mentioned that this a regression. Which versions of LibreOffice
> display the RTF file correctly?

It doesnt happen in 4.0.
Comment 7 Andras Timar 2014-04-22 10:14:05 UTC

*** This bug has been marked as a duplicate of bug 76633 ***
Comment 8 Yousuf Philips (jay) (retired) 2014-04-22 10:49:21 UTC
i do not think this is a duplicate of the other bug.
Comment 9 Michael Meeks 2014-04-22 13:07:28 UTC
Hi Jay; lets see - I suspect Andras knows what he's doing (unless he got the wrong issue#). RTF files have a habit of loosing data past the point where we first failed to parse them properly. Thanks for filing though !
Comment 10 Yousuf Philips (jay) (retired) 2014-04-22 13:22:31 UTC
Hi Michael, well data isnt being lost with this opening of the RTF, data is simply being hidden the UI. To confirm this, i saved the rtf file as a odt and the it was back to normal.
Comment 11 Robinson Tryon (qubit) 2014-04-22 18:52:12 UTC
(In reply to comment #3)
> (In reply to comment #0)
> > I opened the docx file at <
> > http://www.microsoft.com/investor/reports/ar13/docs/2013_Annual_Report.docx
> > > and then saved it as an rtf. then i opened the rtf file and the left half
> > of all pages are missing. I can still select the text that appears on the
> > page, but something is causing it to be invisible.
> 
> CONFIRMED on Ubuntu 12.04.4 + LO 4.2.3.3
> Status -> NEW

Note: if I open the 2013_Annual_Report.docx file and remove all images, then convert the file to RTF and close/reopen the file, I do not see this behavior. This result suggests that bug 76633 and this problem may be related and/or the same bug.
Comment 12 Yousuf Philips (jay) (retired) 2014-04-22 21:39:51 UTC
one the document repaginates to 318 pages, (In reply to comment #11)
> (In reply to comment #3)
> > (In reply to comment #0)
> > > I opened the docx file at <
> > > http://www.microsoft.com/investor/reports/ar13/docs/2013_Annual_Report.docx
> > > > and then saved it as an rtf. then i opened the rtf file and the left half
> > > of all pages are missing. I can still select the text that appears on the
> > > page, but something is causing it to be invisible.
> > 
> > CONFIRMED on Ubuntu 12.04.4 + LO 4.2.3.3
> > Status -> NEW
> 
> Note: if I open the 2013_Annual_Report.docx file and remove all images, then
> convert the file to RTF and close/reopen the file, I do not see this
> behavior. This result suggests that bug 76633 and this problem may be
> related and/or the same bug.

after reopening the non-image file, wait for the document to repaginate to 318 pages (shouldnt take more than 15 seconds) and then half the page will disappear again. One weird thing i noticed while delete the images is that if you delete the second image on page 16, the cursor will jump to the previous page after you delete it. I did some more investigation and i see that the document has some 'drawing object' in the margin that maybe the cause of this problem. See the screenshots.
Comment 13 Yousuf Philips (jay) (retired) 2014-04-22 21:40:53 UTC
Created attachment 97783 [details]
hidden object in the top left corner of document
Comment 14 Yousuf Philips (jay) (retired) 2014-04-22 21:41:45 UTC
Created attachment 97784 [details]
right-clicking on the object
Comment 15 Michael Stahl (CIB) 2014-06-13 19:35:38 UTC

*** This bug has been marked as a duplicate of bug 76633 ***
Comment 16 Robinson Tryon (qubit) 2015-12-15 11:00:13 UTC Comment hidden (obsolete)