Download it now!
Bug 77600 - FILESAVE: saved rtf looses formatting after link
Summary: FILESAVE: saved rtf looses formatting after link
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:4.3.0 target:4.2.5
Keywords:
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2014-04-18 02:49 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-09-29 11:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
shows a paragraph outputted in odf and rtf (48.03 KB, image/jpeg)
2014-04-18 02:49 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-04-18 02:49:13 UTC
Created attachment 97552 [details]
shows a paragraph outputted in odf and rtf

I opened the docx file at < http://www.microsoft.com/investor/reports/ar13/docs/2013_Annual_Report.docx > and then saved it as an rtf. then i opened the rft file and noticed that some text formatting wasnt retained. This has been tested on 4.2, 4.1, and 4.0. There is more than one instance of this issue in the file. The problem seems to be caused by style formatting being closed after a link.
Comment 1 Commit Notification 2014-04-22 11:11:47 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8e8f9388c323ad3c32cef3f91609ad19386b7d56

Related: fdo#77600 RTF import: RTFValue::equals: compare attribute content



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Commit Notification 2014-04-22 13:09:25 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=55c832d86e6cb06e9d6423ce5e6245189bc80da1

fdo#77600 RTF export: always close URL's before the end of run



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Miklos Vajna 2014-04-22 13:13:58 UTC
The first problem was master-only, the second happens in 4.2 as well.

libreoffice-4-2 review: https://gerrit.libreoffice.org/9124
Comment 4 Commit Notification 2014-04-22 16:21:55 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f0a169c8c7173d469ff628b3bd32ff0020a269e2&h=libreoffice-4-2

fdo#77600 RTF export: always close URL's before the end of run


It will be available in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Yousuf Philips (jay) (retired) 2014-04-23 06:00:42 UTC
confirmed testing in 4.2.5 went successfully.