Bug Hunting Session
Bug 77645 - Standard context menu for formula bar input is needed
Summary: Standard context menu for formula bar input is needed
Status: RESOLVED DUPLICATE of bug 57000
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-18 13:33 UTC by A (Andy)
Modified: 2018-04-17 13:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description A (Andy) 2014-04-18 13:33:09 UTC
Problem Description: 
Currently it is not possible to insert text in the text field at the top with a right mouse click.

Steps to Reproduce:
1. Open CALC
2. Copy text from any software application (like MS Editor, LO Writer, etc.) into the clipboard
3. Go to any cell in the CALC spreadsheet and put the cursor in the text field at the top
4. Try to make a right mouse click to insert the text from the clipboard

Current Behavior:
Nothing happens, no context menu opens.

Expected Behavior:
It would be good to have the possibilty to copy text from the clipboard with a right mouse click like you can do it via EDIT -> PASTE or via pressing CTRL + V. 


Reproduced on LO 4.2.3.3, Win 8.1
Comment 1 Joel Madero 2014-07-16 21:03:37 UTC
Valid enhancement request but asking for UX Advice - more context menus can be problematic.


New (confirmed as valid on Ubuntu 14.04)
Enhancement
Lowest - really not a big deal, you can easily do ctrl+v or paste directy into cell with context menu.

@UX Team - if it won't be fixed please set to WONTFIX
Comment 2 Heiko Tietze 2015-02-25 18:57:02 UTC
Works out of the box in 4.4 under Linux. Still an issue?
Comment 3 A (Andy) 2015-02-25 19:31:02 UTC
(In reply to Heiko Tietze from comment #2)
> Works out of the box in 4.4 under Linux. Still an issue?

Unfortunately, I can still reproduce it.  Have you tried to insert the copied text in the Input Line at the top (above the CALC sheet) with a right mouse click?
Comment 4 Joel Madero 2015-02-25 21:16:31 UTC
Verified still on:
ubuntu 14.10 x64
LibreOffice 4.4.1.2 rc
Comment 5 Heiko Tietze 2015-02-26 14:10:01 UTC
I though you mean to paste into a "text box". Yes, there is still no context menu for the formula input line (or memo when expanded, which has a very strange interaction). So I'd agree that for sake of consistency a standard context menu should be applied that contains of Undo, Cut, Copy, Paste, Delete, Select All, Special Character (most items would be disabled always).
Comment 6 Robinson Tryon (qubit) 2016-08-25 04:44:55 UTC Comment hidden (obsolete)
Comment 7 Heiko Tietze 2017-08-08 15:33:51 UTC
Please add a standard context menu to the formula editor. The menu should allow to Cut, Copy, Paste, Delete, Select All, Cancel and Accept. We could extend it with some often used equations such as Sum, Mean, Min, Max, etc. but I wouldn't overdesign this alternative workflow.

Changed the title from "Impossible to insert text in the text field with right mouse click" to something probably more clear and removed UX.
Comment 8 V Stuart Foote 2017-08-08 15:55:18 UTC
Was never there so guess it is not missing, but it is needed :)
Comment 9 Maxim Monastirsky 2018-04-17 13:08:18 UTC

*** This bug has been marked as a duplicate of bug 57000 ***