Download it now!
Bug 77669 - clipboard protocol is broken: raw text is inserted only
Summary: clipboard protocol is broken: raw text is inserted only
Status: RESOLVED DUPLICATE of bug 78801
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-19 10:41 UTC by student975
Modified: 2014-06-07 22:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description student975 2014-04-19 10:41:01 UTC
Starting from 4.2.3-RC (RC is tested in Mint/libreoffice ppa and 4.2.3 release is tested on Arch Linux) inserting formatted text into Writer document (say, inserting of some fragment selected in Firefox) doesn't preserve formatting (styles, colors, sizes, and so on) as it does up to 4.2.2 inclusive. Both ways are broken now: via Ctrl-C/Ctrl-V and via Linux mouse buffer.

P.S. It is absolute stopper for me as far as gathering articles from net into Writer document is the main and almost the way I use LO, but I'm not sure I must set severity above normal.
Comment 1 Luuk 2014-04-19 11:08:44 UTC
I'm not sure if this changed, but pasting using 'Edit/Paste Special' (Ctrl+Shit+V) gives the option to paste with the HTML format preserved.
Comment 2 student975 2014-04-19 11:15:59 UTC
(In reply to comment #1)
> I'm not sure if this changed, but pasting using 'Edit/Paste Special'
> (Ctrl+Shit+V) gives the option to paste with the HTML format preserved.

Exactly, thanks for discovering! Unfortunately I haven't found a way to paste preserving format at one step as far as there are few paste related commands and there isn't a command to insert keeping format.
Comment 3 student975 2014-04-19 11:19:46 UTC
Also there isn't a way to use Linux mouse buffer (say, I must fill in clipboard with Ctrl-C rather to select something with mouse and then insert it into Writer with third mouse button).
Comment 4 Luuk 2014-04-19 13:46:50 UTC
I just tested in LO 3.6 and it seems that default behaviour changed.

In 3.6 a text selected in a browser was pasted in writer keeping the format.
In 4.2.3 the format is lost unless doing a special-paste... ;(

Maybe an option should be added to the settings, specifying wat default to do when pasting? (but than this is not a bug, but a feature request....)
Comment 5 student975 2014-04-19 13:52:20 UTC
(In reply to comment #4)
> In 3.6 a text selected in a browser was pasted in writer keeping the format.
> In 4.2.3 the format is lost unless doing a special-paste... ;(

Last working version is 4.2.2.

> (but than this is not a bug, but a feature request....)

Hm.. I see, lost functionality (say, using mouse buffer for inserting formatted text) can be treated as a bug from user's POV and as something else from developer's POV :) Aside jokes, of course, issue status must be set to be handy for developers.
Comment 6 G.Ostner (LOBugs) 2014-05-26 11:59:22 UTC
Some time between 4.1.3 (I think – I have it no longer installed) and 4.1.6 the default clipboard format for pasting HTML was changed from HTML to plain text ("Unformatierter Text" in German).
Steps to reproduce:
Open Firefox, select text and copy selected text 
Open Libreoffice Writer and paste using Ctrl-V (or Edit/Paste)

Result: Plain text is pasted from clipboard
Expected Result: Rich text (HTML) including formatting is pasted from clipboard

This is true for the latest update from openSUSE 12.3 repo Libreoffice Stable (Libreoffice 4.1.6.3? - I am writing this on Windows), and I've also checked it on Windows 7 (64bit) with Libreoffice 4.1.6.2 and Libreoffice 4.2.4.2. Both have the same bug.

As a side effect, I can no longer paste formatted text under Linux by simply middle-clicking in Writer after selecting it in another window since the default clipboard format is plain text.

I've run a few more tests with 4.2.4.2 under Win7/64 and have found the following:
1. Writer: Strg-V pastes plain text, Ctrl-Shift-V offers "HTML" and "HTML (without comments)" as alternatives. Here the new behaviour is just an annoyance, because I have to remember to press Ctrl-Shift-V (Edit/Paste Special) and select HTML every time I paste text.
2. Calc still pastes formatted text by default, but not all attributes: Textcolor YES, Texthighlight NO
3. Impress: Impress ALWAYS pastes plain text, it’s also the only format offered on Invoking "Paste Special".
4. Draw: same as Impress

So this seems a bug with system-wide consequences.

This can't be a feature, I hope: Why should a user have to give up some information (= text formatting) by default?

I think the most sensible would be to have "HTML (without comments)" as the default clipboard format: that way one would lose no important formatting information, but the huge number of HTML comments inserted by many CMS-based websites would not need removing.
Comment 7 manj_k 2014-06-07 22:23:09 UTC
Very probably a duplicate of Bug 78801 - "Copying HTML from web browser - only plain text is pasted".

Please check the bugfix with version 4.3.0.0.beta2.
(Successfully tested with LibreOfficeDev 4.3.0.0.beta2 on Windows 7.)

*** This bug has been marked as a duplicate of bug 78801 ***