Bug 77687 - FORMATTING: LibreOffice draw hangs when attempting to format line
Summary: FORMATTING: LibreOffice draw hangs when attempting to format line
Status: RESOLVED DUPLICATE of bug 73115
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: x86 (IA32) Linux (All)
: lowest normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-20 09:34 UTC by Paul Dallas
Modified: 2014-05-06 18:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
LibreOffice Draw file where the bug has been observed (22.93 KB, application/vnd.oasis.opendocument.graphics)
2014-04-20 09:34 UTC, Paul Dallas
Details
To make life easier, I am attaching a new version of this file, displaying a very obvious, thick red line! The effect and process for observing the bug is the same as before. Thanks! (22.93 KB, application/vnd.oasis.opendocument.graphics)
2014-04-21 18:35 UTC, Paul Dallas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Dallas 2014-04-20 09:34:24 UTC
Created attachment 97638 [details]
LibreOffice Draw file where the bug has been observed

Problem description: 
When trying to format a line through the right-click menu, LibreOffice Draw only displays the frame of the "Line" dialog box, then hangs.

Steps to reproduce:
1. Open the attached .odg file.
2. Right-click on the dashed red line, and select Line...

Current behavior:
LibreOffice displays the frame of the "Line" dialog box, then hangs.

Expected behavior:
The "Line" dialog box should appear, allowing the line settings to be adjusted.
              
Operating System: Linux (Other)
Version: 4.1.5.3 release
Comment 1 retired 2014-04-20 10:07:49 UTC
Which red line exactly do you mean? Sorry can't find it, but might be blind here.
Comment 2 Paul Dallas 2014-04-21 18:31:05 UTC
Comment on attachment 97638 [details]
LibreOffice Draw file where the bug has been observed

The "red line" in question is a dashed line on the top left corner. To make life easier, I am attaching a second version of this file below, displaying a very obvious, thick red line! The effect and process for observing the bug is the same as before.
Thanks!
Comment 3 Paul Dallas 2014-04-21 18:35:02 UTC
Created attachment 97697 [details]
To make life easier, I am attaching a new version of this file, displaying a very obvious, thick red line! The effect and process for observing the bug is the same as before. Thanks!

To make life easier, I am attaching a second version of this file below, displaying a very obvious, thick red line! The effect and process for observing the bug is the same as before.
Thanks!
Comment 4 sophie 2014-04-29 15:33:21 UTC
Hi, I couldn't reproduce using 4.1.6.1 on Debian 6 or 4.2.4.1 on Ubuntu 14.04 Clicking the red line didn't make LO hang. Left as unconfirmed - Sophie
Comment 5 Paul Dallas 2014-04-30 17:59:15 UTC
Dear Sophie, thanks for checking it out! The problem occurs when you *right* click on the red line and from the pop-up menu you then select Line...
I suppose this is what you tried, and it's good to know it worked in your setup.
I run OpenSuse 13.1 and KDE, with the release of LibreOffice (4.1.5.3) which comes with the (latest update of) the OpenSuse distro.
This issue might well be distribution related; when I get a spare moment, I'll download LibreOffice directly from the LibreOffice repo and give it a go.
Comment 6 Paul Dallas 2014-05-06 17:53:53 UTC
OK, so here's the lowdown for anyone who may be interested:

This problem appears to be related to LibreOffice 4.1.5.3 build-ID 410m0(Build:3), which is bundled with OpenSuse 13.1 (I run KDE).

I tried this on two separate fresh installs of OpenSuse 13.1 on different machines, with the same result.

Uninstalling OpenSuse 13.1 distro's LibreOffice 4.1.5.3 and installing from the .rpms provided on the LibreOffice website solves the problem:
-> The problem does NOT appear on version 4.1.6.2, when installed using .rpms from the LibreOffice website (LibreOffice_4.1.6_Linux_x86_rpm.tar.gz).
-> The problem ALSO does NOT appear on version 4.2.3.3, when installed using .rpms from the LibreOffice website (LibreOffice_4.2.3_Linux_x86_rpm.tar.gz).

I don't know whether the problem is with LibreOffice 4.1.5.3, or with the way it is built (and the way its dependencies are handled) in OpenSuse 13.1. I'll investigate further, and go and complain to OpenSuse.

I think this bug report can just be deleted; I don't think it offers much here.

Thanks!
Comment 7 Maxim Monastirsky 2014-05-06 18:16:33 UTC

*** This bug has been marked as a duplicate of bug 73115 ***