Bug Hunting Session
Bug 77691 - RTL: Text align right is lost when importing a pptx
Summary: RTL: Text align right is lost when importing a pptx
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA (target:4.4.0)
Keywords:
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2014-04-20 16:48 UTC by Ofir
Modified: 2017-02-26 10:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
pptx with text aligned to the right (34.82 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2014-04-20 16:48 UTC, Ofir
Details
PowerPoint PDF export with the correct text alignment (43.59 KB, application/pdf)
2014-04-20 16:51 UTC, Ofir
Details
LibreOffice PDF export with a wrong text alignment (14.65 KB, application/pdf)
2014-04-20 16:59 UTC, Ofir
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ofir 2014-04-20 16:48:26 UTC
Created attachment 97641 [details]
pptx with text aligned to the right

Problem description:
Text doesn't have the correct alignment when importing a pptx.

Steps to reproduce:
1. Import the attached pptx.

Current behavior:
The text is aligned to the left.

Expected behavior:
The text should be align to the right.
Operating System: Windows 7
Version: 4.2.2.1 release
Comment 1 Ofir 2014-04-20 16:51:21 UTC
Created attachment 97642 [details]
PowerPoint PDF export with the correct text alignment
Comment 2 Ofir 2014-04-20 16:55:30 UTC
Also reproduced in Ubuntu 14.04 LO 4.2.3.3
Comment 3 Ofir 2014-04-20 16:59:00 UTC
Created attachment 97643 [details]
LibreOffice PDF export with a wrong text alignment
Comment 4 Julien Nabet 2014-04-20 18:17:34 UTC
On pc Debian x86-64 with master sources updated today, indeed the lines begin to the left and not to the right.
Comment 5 Ofir 2015-02-06 00:49:02 UTC
Fixed in 4.4.0.3 (Ubuntu 14.04)
Comment 6 Julien Nabet 2015-02-06 06:31:46 UTC
just nitpicking, WFM instead of FIXED since there's no specific patch about it.