Download it now!
Bug 77765 - FORMATTING: Page footer numbering duplicates on each save when using alternate right/left footer content
Summary: FORMATTING: Page footer numbering duplicates on each save when using alternat...
Status: RESOLVED DUPLICATE of bug 82165
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: BSA
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-04-22 13:02 UTC by coriolanweihrauch
Modified: 2015-12-17 07:57 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Zip file containing screenshots in version 4.1.1.2 (correct) and 4.2.3003 (wrong) and sample ODT file used for screenshots (385.19 KB, application/zip)
2014-04-22 13:02 UTC, coriolanweihrauch
Details
how the footer right corner looks on even pages in LibO 4.0 VS 4.2.4 (258.21 KB, image/png)
2014-06-09 15:01 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description coriolanweihrauch 2014-04-22 13:02:00 UTC
Created attachment 97745 [details]
Zip file containing screenshots in version 4.1.1.2 (correct) and 4.2.3003 (wrong) and sample ODT file used for screenshots

Hi,

I have a template document which have been using since many Openoffice and Libreoffice version.

Since after *around* (I haven't pinpointed the exact version) version 4.1.12, each time I open the file, a new page number appears in the footer of *even* pages (I have "same content on Left/right" untucked under page style > footer > footer on).

If I save the file with the extra number, next time another number will appear.

This bug does *not* appear in version 4.1.1.2

I have attached screenshots of both versions as well as the test file used to generate these screenshots.

Regards
Coriolan
Operating System: Mac OS X
Version: 4.1.4.2 release
Last worked in: 4.1.1.2 release
Comment 1 Yousuf Philips (jay) (retired) 2014-06-09 15:00:17 UTC
Confirmed in Linux Mint in 4.1.6, 4.2.4 and 4.3 beta. It is not present in 4.0.6.
Comment 2 Yousuf Philips (jay) (retired) 2014-06-09 15:01:06 UTC
Created attachment 100750 [details]
how the footer right corner looks on even pages in LibO 4.0 VS 4.2.4
Comment 3 Xisco Faulí 2014-06-11 13:36:17 UTC
bibisected:

There are only 'skip'ped commits left to test.
The first bad commit could be any of:
18ee045c7e35e5ae98cffaafd56fb6fb37d7afcf
33ac6698e6d90d84f99d784b9553ee87eec27d6a
We cannot bisect more!

# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect bad 4850941efe43ae800be5c76e1102ab80ac2c085d
# skip: [a043626b542eb8314218d7439534dce2fc325304] source-hash-9379a922c07df3cdb7d567cc88dfaaa39ead3681
git bisect skip a043626b542eb8314218d7439534dce2fc325304
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# good: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect good c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# good: [30cde618212ecaf5725321372bd1b8339f8e2b9f] source-hash-137f872aa8e6e598e7c7ed1ffa4d21e580e22bdb
git bisect good 30cde618212ecaf5725321372bd1b8339f8e2b9f
# good: [30cde618212ecaf5725321372bd1b8339f8e2b9f] source-hash-137f872aa8e6e598e7c7ed1ffa4d21e580e22bdb
git bisect good 30cde618212ecaf5725321372bd1b8339f8e2b9f
# good: [306d62ec4b911895f08f2bb8efefebed7ac795f0] source-hash-735bd120c9ee2d9bb3514907936c27efb75d7282
git bisect good 306d62ec4b911895f08f2bb8efefebed7ac795f0
# skip: [18ee045c7e35e5ae98cffaafd56fb6fb37d7afcf] source-hash-fe506f34f2dccb6562935fe4dfbc1fe6d609dec8
git bisect skip 18ee045c7e35e5ae98cffaafd56fb6fb37d7afcf
# good: [2a3d9160aa946746b49f306e4f8cc5ddcd27d922] source-hash-cff891fc44adcca745bcaa9ae95483bd63aa05ae
git bisect good 2a3d9160aa946746b49f306e4f8cc5ddcd27d922
# bad: [33ac6698e6d90d84f99d784b9553ee87eec27d6a] source-hash-732c0f929fc0229b6da37d4ec4b6de8994fcea46
git bisect bad 33ac6698e6d90d84f99d784b9553ee87eec27d6a
# good: [114afdde4043b0ea0a52e5c362eb9184e5aef5b4] source-hash-af1ac453dfb6041ba04a50117a481739c10307ab
git bisect good 114afdde4043b0ea0a52e5c362eb9184e5aef5b4
# good: [4b000297564ab0b23495a88354a595e285dcd899] source-hash-bda58c33afe9a9f6ca4f8b27bff44ba2c22da395
git bisect good 4b000297564ab0b23495a88354a595e285dcd899
# only skipped commits left to test
# possible first bad commit: [33ac6698e6d90d84f99d784b9553ee87eec27d6a] source-hash-732c0f929fc0229b6da37d4ec4b6de8994fcea46
# possible first bad commit: [18ee045c7e35e5ae98cffaafd56fb6fb37d7afcf] source-hash-fe506f34f2dccb6562935fe4dfbc1fe6d609dec8
Comment 4 Michael Stahl (CIB) 2014-08-15 14:46:10 UTC

*** This bug has been marked as a duplicate of bug 82165 ***
Comment 5 Robinson Tryon (qubit) 2015-12-17 07:57:39 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]