Bug Hunting Session
Bug 77840 - FORMATTING: SWF export accuracy
Summary: FORMATTING: SWF export accuracy
Status: RESOLVED DUPLICATE of bug 50792
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-23 22:36 UTC by Joshua
Modified: 2014-10-06 15:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ODP with timed transitions added in (17.07 KB, application/vnd.oasis.opendocument.presentation)
2014-07-21 01:07 UTC, Joshua
Details
SWF exported that's supposed to have timed transitions, but reverted to clicks (3.95 KB, application/x-shockwave-flash)
2014-07-21 01:10 UTC, Joshua
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joshua 2014-04-23 22:36:46 UTC
Problem description: 
Exporting a SWF from a presentation loses automatically happening transitions (animations set to happen after a previous animation or after entering slide), loses slide transitions, and looses automatic actions instead requiring mouse clicks to proceed.

Steps to reproduce:
1. Create a presentation that uses object animations and transitions
2. export to swf
3. watch swf

Current behavior:
An SWF made from an automated and animated presentation is not automated or animated, despite SWF files being able to contain such data.

Expected behavior:
An SWF exported functioning identically (or at least nearly identically) to the presentation. 
Operating System: Windows 7
Version: 4.1.5.3 release
Comment 1 Joel Madero 2014-07-20 05:36:48 UTC
Please attach a sample document. Marking as NEEDINFO - once you attach a sample presentation set to UNCONFIRMED. Thanks
Comment 2 Joshua 2014-07-21 01:07:04 UTC
Created attachment 103162 [details]
ODP with timed transitions added in

This is an ODP with timed transitions added that work.
Comment 3 Joshua 2014-07-21 01:10:05 UTC
Created attachment 103163 [details]
SWF exported that's supposed to have timed transitions, but reverted to clicks

This is a SWF generated by exporting from the same-named ODP. Using it reveal that transitions have disappeared, replaced with a click-slide-show that goes between static slides. Considering SWFs have support for timing, this is odd behavior, in addition to making Libre Office Presentations useless for many web-based uses they should be ideal for.
Comment 4 Joshua 2014-07-21 01:11:20 UTC
As requested, sample documents have been attached. Both a source ODP and a resulting SWF have been attached. The differences between the two files demonstrates that timing aspects are removed by the export to SWF files.
Comment 5 Robinson Tryon (qubit) 2014-07-27 17:27:42 UTC
CONFIRMED on Ubuntu 12.04.4 + LO 4.3.0.3 and FF 30

(In reply to comment #0)
> Steps to reproduce:
> 1. Create a presentation that uses object animations and transitions
> 2. export to swf
> 3. watch swf

Confirmed -- The exported SWF does not include the same animations as are present in the ODP file.

I don't know if we've ever exported animations into SWF, so I agree that this is most likely an enhancement.
Comment 6 Joshua 2014-07-27 20:18:00 UTC
(In reply to comment #5)
> CONFIRMED on Ubuntu 12.04.4 + LO 4.3.0.3 and FF 30
> 
> (In reply to comment #0)
> > Steps to reproduce:
> > 1. Create a presentation that uses object animations and transitions
> > 2. export to swf
> > 3. watch swf
> 
> Confirmed -- The exported SWF does not include the same animations as are
> present in the ODP file.
> 
> I don't know if we've ever exported animations into SWF, so I agree that
> this is most likely an enhancement.

In the spirit of giving this a proper status, I have to admit I wasn't sure what importance to give it as a Libre Office User. Since it affects my primary use of Libre Office, I would have personally given it highest, but chose as medium as I don't know how many others would view it the same. But here's my thoughts (if this kind of thing doesn't belong here, feel free to delete).

1. For posting things to view (including presentations) online SWF files are one of the standards. (Great example: Youtube accepts the uploading of SWF files for videos, and people embed Youtube videos for site presentations everywhere.) 

2. The posting-online-aspect greatly affects program use in our internet-heavy world. 

3. At present, to try and get a more accurate conversion into SWF,  pretty much every conversion tool or method to get an ODP into SWF format ends up having to require conversion to PPT. This not only loses data inherent to the ODP, but also makes a prime competitor a necessary step. 

4. online presentations are VERY visible. When some list credits and include the program they used, that's a lot more exposure for LibreOffice if it streamlines the process.
Comment 7 Joshua 2014-07-27 20:18:42 UTC
(In reply to comment #5)
> CONFIRMED on Ubuntu 12.04.4 + LO 4.3.0.3 and FF 30
> 
> (In reply to comment #0)
> > Steps to reproduce:
> > 1. Create a presentation that uses object animations and transitions
> > 2. export to swf
> > 3. watch swf
> 
> Confirmed -- The exported SWF does not include the same animations as are
> present in the ODP file.
> 
> I don't know if we've ever exported animations into SWF, so I agree that
> this is most likely an enhancement.

In the spirit of giving this a proper status, I have to admit I wasn't sure what importance to give it as a Libre Office User. Since it affects my primary use of Libre Office, I would have personally given it highest, but chose as medium as I don't know how many others would view it the same. But here's my thoughts (if this kind of thing doesn't belong here, feel free to delete).

1. For posting things to view (including presentations) online SWF files are one of the standards. (Great example: Youtube accepts the uploading of SWF files for videos, and people embed Youtube videos for site presentations everywhere.) 

2. The posting-online-aspect greatly affects program use in our internet-heavy world. 

3. At present, to try and get a more accurate conversion into SWF,  pretty much every conversion tool or method to get an ODP into SWF format ends up having to require conversion to PPT. This not only loses data inherent to the ODP, but also makes a prime competitor a necessary step. 

4. online presentations are VERY visible. When some list credits and include the program they used, that's a lot more exposure for LibreOffice if it streamlines the process.
Comment 8 ign_christian 2014-10-06 15:00:05 UTC

*** This bug has been marked as a duplicate of bug 50792 ***