Bug Hunting Session
Bug 77877 - Incomplete Hyperlink support in indexes and tables
Summary: Incomplete Hyperlink support in indexes and tables
Status: RESOLVED DUPLICATE of bug 71385
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-24 07:56 UTC by Ulrich Windl
Modified: 2014-04-24 08:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Windl 2014-04-24 07:56:10 UTC
At some point Writer "invented" the "LS" and "LE" tags to include explicit hyperlinks for automatically generated tables. Unfortunately that change was made very "narrow-minded":
1) It took me quite some time to find out about this change (poorly documented)
2) Old documents aren't "upgraded" automatically, to older documents that had working hyperlinks in table of contents (TOC) now don't have working hyperlinks until you manually add LS and LE tags at the right places in the table definition.
So far for the past, but now the real point:
3) Not all types of tables allow inserting LS and LE tags:
Table of contents: OK
Index: not OK
Table of figures (images): not OK
Table of tables: not OK
User-defined tables: not OK
Table of objects: not OK

I see no point why LSS and LE are restricted to TOC. Please fix the implementation, or revert to something sane!
Comment 1 sophie 2014-04-24 08:40:26 UTC
Hi, don't put your own request on New until it has been confirmed by a QA member. This is a duplicate of bug 71385 - Sophie

*** This bug has been marked as a duplicate of bug 71385 ***