Download it now!
Bug 77890 - FILESAVE: LO gives Input/Output Error message while opening the file.( page break is getting converted to section break if different first page is set in doc)
Summary: FILESAVE: LO gives Input/Output Error message while opening the file.( page b...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Umesh Kadam
URL:
Whiteboard: BSA target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-24 12:10 UTC by Umesh Kadam
Modified: 2014-05-09 21:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
File contains TOC and foot note (206.42 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-04-24 12:10 UTC, Umesh Kadam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Umesh Kadam 2014-04-24 12:10:56 UTC
Created attachment 97898 [details]
File contains TOC and foot note

Problem description: 

Steps to reproduce:
1. Open the Original file 342_Original.docx in LO
2. Save as 342_Original_RT.docx
3. Open the file 342_Original_RT.docx in LO
4. Save as 342_Original_RT_1.docx
5. Try opening the file 342_Original_RT_1.docx in LO

Current behavior:
LO gives Input/Output Error message while opening the file.

Expected behavior:
The file should open without any error messages.
              
Operating System: All
Version: 4.3.0.0.alpha0+ Master
Comment 1 Jorendc 2014-04-25 20:12:44 UTC
@Umesh: looks like a dupe/highly related to bug 77725 ?

Please feel free to reopen if I'm not correct.

Kind regards,
Joren

*** This bug has been marked as a duplicate of bug 77725 ***
Comment 2 Umesh Kadam 2014-05-02 09:07:01 UTC
The issue in this file is different and is not duplicate of 
In this case the following is the behavior:
1) During the first round-trip the page break on the first page is converted to a section break(next page )
2) During the second round-trip the section break information is lost, due to which the TOC is spanned across three pages( first, second and third )
   whereas it should have been on one single page( second page in original file).
3) Due to this overflow of the TOC the following pages get disrupt and hence the footnotes.
4) Therefore while importing the second RT(342_Original_RT_1.docx) LO does not find the relevant footnotes and hence raises exception.

This scenario is observed only in case if there is a different first page is set.

Fixing the 1st point ( aforementioned ) will fix this issue.
Comment 3 Commit Notification 2014-05-09 06:35:56 UTC
umeshkadam committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e9b2787c2ece4c8260fbac6359257e1829c917d4

fdo#77890: page break exported as section break if different 1st page is set



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Jorendc 2014-05-09 21:14:27 UTC
Looks fixed to me. I can not reproduce this anymore, tested using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha1+
Build ID: e9b2787c2ece4c8260fbac6359257e1829c917d4
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-09_06:36:37

Kind regards,
Joren