Bug 77910 - LibreOffice doesn’t detect TTC fonts such as Cambria and Sitka under Linux, the OS does
Summary: LibreOffice doesn’t detect TTC fonts such as Cambria and Sitka under Linux, t...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.4.0 target:4.3.3
Keywords:
Depends on:
Blocks: Font-Formats
  Show dependency treegraph
 
Reported: 2014-04-25 04:13 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-11-04 10:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
the mentioned docx file (1.24 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-04-25 04:13 UTC, Yousuf Philips (jay) (retired)
Details
regular not listed under font style (99.08 KB, image/jpeg)
2014-04-25 04:21 UTC, Yousuf Philips (jay) (retired)
Details
Side by side 4.3 dev and MS Office 2013 (764.57 KB, image/png)
2014-04-25 06:40 UTC, Florian Reisinger
Details
libO 4.3 on linux is the same (124.47 KB, image/png)
2014-04-25 09:03 UTC, Yousuf Philips (jay) (retired)
Details
cambria regular installed (125.89 KB, image/jpeg)
2014-04-25 15:19 UTC, Yousuf Philips (jay) (retired)
Details
output of fc-list (22.93 KB, text/plain)
2014-04-25 16:44 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-04-25 04:13:57 UTC
Created attachment 97932 [details]
the mentioned docx file

I visited office.com and created the attached document to see how well it would open in libreoffice and the title of the page is rendering as Cambria Italic rather than just Cambria Regular, as regular is not listed under font style.
Comment 1 Yousuf Philips (jay) (retired) 2014-04-25 04:21:52 UTC
Created attachment 97933 [details]
regular not listed under font style
Comment 2 Florian Reisinger 2014-04-25 06:40:17 UTC
Created attachment 97939 [details]
Side by side 4.3 dev and MS Office 2013

Can't confirm that. I do see that the image is not as beatiful as on Word, but for that please open another bug
Comment 3 Florian Reisinger 2014-04-25 06:40:37 UTC
Sorry for the typo *beautiful...
Comment 4 Yousuf Philips (jay) (retired) 2014-04-25 09:01:19 UTC
Maybe its fine on windows but it isnt on linux. I just tested 4.3 dev and its no different. Have attached for confirmation.
Comment 5 Yousuf Philips (jay) (retired) 2014-04-25 09:03:07 UTC
Created attachment 97946 [details]
libO 4.3 on linux is the same
Comment 6 Yousuf Philips (jay) (retired) 2014-04-25 09:09:56 UTC
I wasnt thinking to submit a bug reprort for the image as i thought it would be low priority at the moment as ms office has alot of image effects. Just a note, when i right-clicked on the image in 4.3 and selected 'Picture...' the dialog wouldnt fully load.
Comment 7 Florian Reisinger 2014-04-25 13:24:35 UTC
I know the question is silly, but is the font installe. Can a program (!LibO) use the regular version? If so, bug otherwise WORKSFORME. You are right with the pic :)
Comment 8 Yousuf Philips (jay) (retired) 2014-04-25 15:19:18 UTC
Yes the font is installed and shows up correctly in kingsoft writer. If i had to track down the problem, i would possibly say that its because cambria regular comes with the extension .ttc rather than .ttf, as seen in the attachment.
Comment 9 Yousuf Philips (jay) (retired) 2014-04-25 15:19:46 UTC
Created attachment 97963 [details]
cambria regular installed
Comment 10 Luboš Luňák 2014-04-25 15:36:06 UTC
Screenshot in comment #2 suggests you do not have the regular variant installed. Please attach output of 'fc-list'.
Comment 11 Luboš Luňák 2014-04-25 15:37:27 UTC
Also, if you simply create a new document, can you use the regular variant of the font there?
Comment 12 Yousuf Philips (jay) (retired) 2014-04-25 16:43:24 UTC
I'm able to select cambria regular in kingsoft writer and calligra words, only not able to select it in libreoffice writer. I have attached the output of fc-list and "Calibri:style=Regular" is listed.
Comment 13 Yousuf Philips (jay) (retired) 2014-04-25 16:44:22 UTC
Created attachment 97970 [details]
output of fc-list
Comment 14 Yousuf Philips (jay) (retired) 2014-04-25 16:47:34 UTC
sorry i meant "Cambria:style=Regular"
Comment 15 Jorendc 2014-04-26 13:10:56 UTC
I have the same result (NOT reproducible) as Florian R. (comment 2)
Tested using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha1+
Build ID: f4a6837025a293312cbc43b9c527851362f11030
TinderBox: Win-x86@47-TDF, Branch:MASTER, Time: 2014-04-26_09:21:18

Kind regards,
Joren
Comment 16 Yousuf Philips (jay) (retired) 2014-04-26 13:39:53 UTC
As previously stated, this seems to be a non-windows issue. :)
Comment 17 Adolfo Jayme 2014-04-29 10:44:55 UTC
This is because LibreOffice does not support TrueType Collection fonts (TTC) under Linux. So, it can’t render Cambria Regular (which is contained in a TTC file together with Cambria Math).

NEW
Comment 18 Yousuf Philips (jay) (retired) 2014-04-29 12:40:07 UTC
Weird that the OS can handle it and so do other linux office suites but LibO cant bring it in.
Comment 19 Adolfo Jayme 2014-05-03 04:54:13 UTC
I can reproduce this with 3.5, so I suspect this is OOo-inherited.

CCing Caolán, who may be interested in this.
Comment 20 Adolfo Jayme 2014-09-12 11:18:57 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=02f8f895f2abc4ee090b4bd42963590aa018fb49

Related: fdo#82259 support version 2 ttc fonts on Linux



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 21 Adolfo Jayme 2014-09-13 16:41:59 UTC
The commits 02f8f895f and 9436ae994 were backported to -4-3: http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-3&id=8618534a73e8c6b5cddb6a7cacedcc38b62bab33