Bug 77912 - FILEOPEN: Excel cell formulas referring to other sheets are changed arbitrarily
Summary: FILEOPEN: Excel cell formulas referring to other sheets are changed arbitrarily
Status: RESOLVED DUPLICATE of bug 74345
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-04-25 06:39 UTC by Abhi
Modified: 2015-12-15 10:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Zip file containing original & corrupted excel files (663.79 KB, application/zip)
2014-04-25 06:39 UTC, Abhi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Abhi 2014-04-25 06:39:51 UTC
Created attachment 97938 [details]
Zip file containing original & corrupted excel files

Problem description: 
When I open an excel file which has cell formulas referring to other sheets (within the same file), Calc resets the column numbers to some arbitrary large value.

Steps to reproduce:
1. Open excel file in Libreoffice.
2. Change some numerical values.
3. Save the file.
4. Open again in Libreoffice

Current behavior:
The formula in cell C4 of sheet STAAD_Comp is originally "=$profil.A6". On saving the file in Calc, the formula gets changed to "=$profil.IW6" Similar changes occur in every cell and on every sheet.

Expected behavior:
Formulas should not change
Operating System: Ubuntu
Version: 4.2.0.4 release
Last worked in: 4.1.5.3 release
Comment 1 m.a.riosv 2014-04-25 08:21:34 UTC
Hi Abhi, thanks for reporting.

I think this is a duplicate, please if you are not agree, reopen it.

*** This bug has been marked as a duplicate of bug 74345 ***
Comment 2 Robinson Tryon (qubit) 2015-12-15 10:54:54 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]