Bug 77950 - EDITING: Cut & Paste doesn't change references in dependent cells. But it's done with drag&drop.
Summary: EDITING: Cut & Paste doesn't change references in dependent cells. But it's d...
Status: RESOLVED DUPLICATE of bug 77944
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-04-25 23:31 UTC by m.a.riosv
Modified: 2014-05-08 01:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2014-04-25 23:31:54 UTC
In a new spreadsheet.

Enter in:
A1: +B1
B1: 1

Crtl+x B1
goto to C1
Ctrl+v

Reference in A1 remains +B1

With drag&drop reference in A1 change to +C1

Version: 4.3.0.0.alpha1+ Build ID: 808d273db098e2269e53813595a6bfc7b160e28e
   TinderBox: Win-x86@39, Branch:master, Time: 2014-04-25_02:09:26

Last working:
Version: 4.2.5.0.0+ Build ID: 08b51bfff61870cd573daea914dce429743f4655
   TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-04-25_12:33:11
Comment 1 Joel Madero 2014-04-26 05:33:45 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.3.0.0.alpha0
Date:   Thu Apr 24 21:43:16 2014 +0300
Platform :Ubuntu 14.04
DE: GNOME3

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Normal: this is not a critical bug as it's not a data loss bug or crasher. Can prevent high quality work (or substantially impact professional work) + regression so normal is correct
High

Keywords - regression confirmed

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 m.a.riosv 2014-04-26 11:59:54 UTC
Thanks for confirmation.

Right it's not critical, it's a blocker for release. 

What must we understand for data lose?

What is leave formulas with incorrect references without any kind notice?, beside a nightmare for an user.

Is it a very basic function in spreadsheets? 

Please can you add to MAB for 4.3 - 75025
Comment 3 Joel Madero 2014-04-26 16:11:10 UTC
This really is not a BLOCKER m.a.riosv (sorry). It actually technically is a minor bug - but I bumped it to normal because it is pretty annoying.

https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg


As you can see to qualify as a blocker/critical/major - you have to have severe problems which completely prevents you from accomplishing professional quality work. This is annoying yes, and it can substantially slow down your ability to do quality work but you aren't losing data. Loss of data means you save a file, open it back up and the data is just gone. 

Please understand that everyone tries to argue that their own bug is a blocker bug and we have to stick to some kind of routine to keep things organized. That being said - this is marked as a regression against master so there will likely be someone looking at it.

If you know how to bibisect it might be useful but you'll have to use the zsync method : https://wiki.documentfoundation.org/QA/HowToBibisect

I don't have the time currently to do it - but like I said, regressions against master tend to get some attention
Comment 4 m.a.riosv 2014-04-26 16:58:07 UTC
I'll better keep out, maybe when one of us learn a bit about spreadsheets, we could discuss about matters like this.
Comment 5 m.a.riosv 2014-05-08 01:15:31 UTC
I think this is a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=77944

Now fixed.

Verified fixed with:
Version: 4.2.5.0.0+ Build ID: bc74773e8c5d62f4fe932366f1fae5bebbd19f65
  TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-05-07_03:55:27

*** This bug has been marked as a duplicate of bug 77944 ***