Download it now!
Bug 77963 - FILEOPEN: WPS DOC - Text has wrong font and image not aligned correctly
Summary: FILEOPEN: WPS DOC - Text has wrong font and image not aligned correctly
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC-Character DOC-Images
  Show dependency treegraph
 
Reported: 2014-04-26 11:35 UTC by Yousuf Philips (jay) (retired)
Modified: 2020-11-06 10:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
how it looks in word 2010 and LibO (61.11 KB, image/jpeg)
2014-04-26 11:35 UTC, Yousuf Philips (jay) (retired)
Details
doc file produced by kingsoft writer (242.50 KB, application/msword)
2014-04-26 11:35 UTC, Yousuf Philips (jay) (retired)
Details
pdf of libreoffice 4.2 (230.76 KB, application/pdf)
2014-04-26 12:48 UTC, Yousuf Philips (jay) (retired)
Details
pdf of word 2010 (453.70 KB, application/pdf)
2014-04-26 12:49 UTC, Yousuf Philips (jay) (retired)
Details
pdf of word 2013 (402.29 KB, application/pdf)
2014-04-26 12:49 UTC, Yousuf Philips (jay) (retired)
Details
DOCX page 5 compared MSO LO (206.55 KB, image/png)
2020-11-06 10:57 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-04-26 11:35:25 UTC
Created attachment 98017 [details]
how it looks in word 2010 and LibO

I download the .docx file found at < http://download.microsoft.com/documents/customerevidence/Files/710000003670/Xiamen_Tungsten_Group_unifies_enterprise.docx > and opened it with kingsoft writer and then saved it as an DOC. When i opened the DOC in LibO, on page 1, it has substituted the font Simsun for Microsoft YaHei, and have center aligned the image when it is supposed to be left margin aligned. Tested in 3.6 - 4.3.
Comment 1 Yousuf Philips (jay) (retired) 2014-04-26 11:35:57 UTC
Created attachment 98018 [details]
doc file produced by kingsoft writer
Comment 2 Jorendc 2014-04-26 12:28:10 UTC
Definatelly not our bug.

I opened your attached .doc, created using Kingsoft writer. Word 2013 opens the first page also with Microsoft YaHei font, and centers the image. This is the same behavior as LibreOffice (as you report).

This looks like an export bug of kingsoft office.

I hope you agree?

Kind regards,
Joren
Comment 3 Yousuf Philips (jay) (retired) 2014-04-26 12:46:28 UTC
sorry i mislabelled the image, word 2010 is the bottom image. :) Maybe i wasnt clear with my wordings, LibreOffice should show the Microsoft YaHei font, but instead is showing Simsun. It substitutes it for most of the text in the document, but not all of it (e.g. the first line is Microsoft YaHei). I just opened the document in word 2013 and the image is not centered.
Comment 4 Yousuf Philips (jay) (retired) 2014-04-26 12:48:56 UTC
Created attachment 98027 [details]
pdf of libreoffice 4.2
Comment 5 Yousuf Philips (jay) (retired) 2014-04-26 12:49:23 UTC
Created attachment 98028 [details]
pdf of word 2010
Comment 6 Yousuf Philips (jay) (retired) 2014-04-26 12:49:43 UTC
Created attachment 98030 [details]
pdf of word 2013
Comment 7 Jorendc 2014-04-26 12:53:46 UTC
(In reply to comment #3)
> sorry i mislabelled the image, word 2010 is the bottom image. :)

Ah yes, that makes sense. I did open the document myself now, using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha1+
Build ID: f4a6837025a293312cbc43b9c527851362f11030
TinderBox: Win-x86@47-TDF, Branch:MASTER, Time: 2014-04-26_09:21:18
I can reproduce the mis-alignment now :-).

> Maybe i wasnt clear with my wordings, LibreOffice should show the Microsoft YaHei
> font, but instead is showing Simsun. It substitutes it for most of the text
> in the document, but not all of it (e.g. the first line is Microsoft YaHei).
> I just opened the document in word 2013 and the image is not centered.

Correct. Although it looks like the fonts are displayed in Chinese, I can see that different font is used for headings and the paragraphs.

Marking as NEW :)

Thanks for your feedback.
Joren
Comment 8 QA Administrators 2015-06-08 14:41:58 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2015-06-21 18:42:47 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)
Comment 10 QA Administrators 2016-09-20 10:10:20 UTC Comment hidden (obsolete)
Comment 11 Yousuf Philips (jay) (retired) 2017-09-29 11:08:25 UTC
Still present

Version: 6.0.0.0.alpha0+
Build ID: 8d2a287da3abb0576512406227d0a3acd602123e
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 12 QA Administrators 2018-09-30 02:46:57 UTC Comment hidden (obsolete, spam)
Comment 13 Justin L 2020-04-17 10:16:09 UTC
Repro 7.0+
I roundtripped this file in both Word 2016 and 2003. In both cases, the font seems to be OK, and the picture is inline (and therefore is not centered).
So do we really care about this one?
Comment 14 Timur 2020-11-06 10:57:44 UTC
Created attachment 167056 [details]
DOCX page 5 compared MSO LO

Could someone explain what this bug is about?
I guess not WPS anymore? 
I don't get font part because of Chinese names. 

1. MSO opens Microsoft YaHei font, which I see I have installed with MSO in Win. 
LO shows 微软雅黑, what's that?
fontTable.xml shows: 
<w:font w:name="宋体">
<w:altName w:val="SimSun"/>

Note Bug 135444.
But fonts looks good in Win here.

2. What's the issue with image? Is it 1st page image? Looks the same to me in LO as in MSO, seen if MSO and LO put vertically and compared. 

3. Only issue I see with original MSO DOCX is page 5 difference because page content stretches beyond margin in MSO, see in attachment. 
Not sure what it is. 
Surely not for this bug. Justin, please see if already reported somewhere, I added you to CC.