Download it now!
Bug 77971 - FORMATTING: Writer: Better font selection in Japanese locale on Mac OSX.
Summary: FORMATTING: Writer: Better font selection in Japanese locale on Mac OSX.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.4.0 target:4.3.5
Keywords:
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2014-04-26 15:23 UTC by Tomofumi Yagi
Modified: 2015-01-29 11:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen shot 1:Basic_Fonts(Asian) 4.1.x or later (208.84 KB, image/png)
2014-04-26 15:23 UTC, Tomofumi Yagi
Details
This patch removes a suffix(w3, w6) from the japanese font name in the VCL.xcu. (6.88 KB, patch)
2014-11-15 04:59 UTC, Tomofumi Yagi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomofumi Yagi 2014-04-26 15:23:04 UTC
Created attachment 98043 [details]
Screen shot 1:Basic_Fonts(Asian) 4.1.x or later

Problem description: 

The problem is that Basic fonts(Asian) are Arial Unicode MS(LibreOffice 4.1.x or later).
Expected behavior is that Basic fonts(Asian) are Hiragino Mincho ProN font.

The root cause of the problem is that we still have not changed font names in VCL.xcu.
Most probably, we need to use only specify the font family name(without weight) in VCL.xcu for LibreOffice 4.1 or later.

Steps to reproduce:
1. Start Writer.
2. Open Preferences.
3. Show Options -> LibreOffice Writer -> Basic Fonts(Asian).

Operating System: Mac OS X
Version: 4.1.3.2 release
Comment 1 Tomofumi Yagi 2014-04-26 15:35:43 UTC
I'm guessing the cause of this bug is that LibreOffice 4.1 or later uses CoreText API instead of ATSUI API.
Comment 2 Tomofumi Yagi 2014-04-27 09:23:09 UTC
I added Khaled Hosny on CC.
Because I was taught he is the expert on Mac CoreText API.
Comment 3 Yousuf Philips (jay) (retired) 2014-06-09 16:40:27 UTC
I've CCed Michael as i know he'll point the issue in the right direction.
Comment 4 Michael Meeks 2014-06-10 14:38:32 UTC
Khaled is really the expert here; I defer to him =)
Comment 5 Alex Thurgood 2014-10-15 12:39:14 UTC
Confirming. 

The same problem exists with CTL languages activated.
Comment 6 Alex Thurgood 2014-10-15 12:43:32 UTC
Confirmed on

Version: 4.4.0.0.alpha0+
Build ID: 7dc6c9af4ba313f054331f5130470d83d875bc16

OSX 10.9.5
Comment 7 Tomofumi Yagi 2014-11-15 04:59:40 UTC
Created attachment 109503 [details]
This patch removes a suffix(w3, w6) from the japanese font name in the VCL.xcu.

LibreOffice 4.1 and later, on Mac OS X, the font family names are kept without suffix in the system font list.
Some font names in VCL.xcu (font family name including the weight as suffix) doesn't match the font name kept in the system font list.
This is the reason that causes the problem.

This problem reproduces at the CJK fonts environment.
The patch resolves this problem with Japanese fonts environment only.
Comment 8 Commit Notification 2014-11-15 15:37:07 UTC
Tomofumi Yagi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=735a1a17648071eee91099d73ef0a8000edf134f

fdo#77971 Writer:Better font selection in Japanese locale on Mac OSX.

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Matthew Francis 2014-11-22 03:03:35 UTC
Verified on 4.4 master - Asian fonts now default to Hiragino when the language or Asian font setting are set to Japanese
Comment 10 Adolfo Jayme 2014-11-23 16:23:26 UTC
Caolán backported the patch to 4-3 as commit ad3da3ba.