Download it now!
Bug 78004 - UI: Solver dialog crashes after running for 24 hours
Summary: UI: Solver dialog crashes after running for 24 hours
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: gulyas.alex
URL:
Whiteboard: target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-27 14:23 UTC by gulyas.alex
Modified: 2014-04-27 17:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gulyas.alex 2014-04-27 14:23:53 UTC
After running the solver for 24 hours, it crashed with a Java Exception. Sadly, I didn't capture the error text, but it happened when the displayed solver run time reached 23:59, and mentioned something about a String formatting error. I think the dialog can't handle displaying times above 1 day, and has nothing to do with the selected solver algorithm (DEPS Evolutionary in this case).

Due to the nature of this bug, I won't try to reproduce it.
Comment 1 gulyas.alex 2014-04-27 16:32:46 UTC
Patch sent to gerrit...
Comment 2 Jorendc 2014-04-27 16:51:36 UTC
(In reply to comment #0)
> Due to the nature of this bug, I won't try to reproduce it.

Hehe, I really agree on that one ;-). Looks like you already did send in a patch. So lets mark as NEW right away.

Thanks for reporting and fixing!

Kind regards,
Joren
Comment 3 Commit Notification 2014-04-27 16:58:38 UTC
Alex Gulyas committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dfbaef22fcc66f86ecdfccb82037fbfd171c975d

fdo#78004 fix string formatting



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Kohei Yoshida 2014-04-27 17:13:52 UTC
I will assume this is fixed.