Bug 78011 - The dropdown in the toolbar only shows the default blue
Summary: The dropdown in the toolbar only shows the default blue
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-04-27 19:52 UTC by Fabian Alexander Wilms
Modified: 2014-06-16 12:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Alexander Wilms 2014-04-27 19:52:07 UTC
Problem description: 
The dropdown in the toolbar only shows the default blue

Steps to reproduce:
1. Start writer
2. Daraw a circle
3. Try to re-color it via the toolbar

Current behavior:
It's not possible

Expected behavior:
It should be possible

Version: 4.3.0.0.alpha1+
Build ID: 7b3ff3882dcaa87e62188ef9300d771321998b20
TinderBox: Win-x86@39, Branch:master, Time: 2014-04-27_11:10:07
Comment 1 Fabian Alexander Wilms 2014-04-27 19:54:15 UTC
Affects dropdown menus for filling and line color.
Comment 2 Jorendc 2014-04-27 20:45:03 UTC
Reproducible, tested using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha1+
Build ID: 145f2e970f46a3a3e5456b122d71f17c3abe878f
TinderBox: Win-x86@42, Branch:master, Time: 2014-04-26_23:32:36

Kind regards,
Joren
Comment 3 Emir Sarı 2014-04-27 20:45:42 UTC
Confirmed using the latest master.
Comment 4 Julien Nabet 2014-04-27 20:57:20 UTC
I noticed that line styles dropdown doesn't show the line but displays their name
Comment 5 Jorendc 2014-04-27 21:06:43 UTC
(In reply to comment #4)
> I noticed that line styles dropdown doesn't show the line but displays their
> name

Thanks to Fabian already reported in bug 78005
Looks like our preview is pretty broken (see bug 78013, 78014 and 78015).
Comment 6 Julien Nabet 2014-04-28 10:41:56 UTC
Just for info, line styles are present now (see https://bugs.freedesktop.org/show_bug.cgi?id=77874#c6) but there's still the dropdown color problem.
Comment 7 Fabian Alexander Wilms 2014-06-16 12:09:10 UTC
Seems to be fixed in Version: 4.3.0.0.beta2
Build-ID: a06aa316117a6ff0f05c697c82831c227812d810