Bug 78029 - Particular dates are replaced by fractions by the autocorrect rules even when cell format is set to date
Summary: Particular dates are replaced by fractions by the autocorrect rules even when...
Status: RESOLVED DUPLICATE of bug 33899
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-28 09:23 UTC by Uli
Modified: 2014-05-02 10:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uli 2014-04-28 09:23:04 UTC
LibreOffice Calc: cell is formatted for date. 
If I input e.g. 3/5 for 3 May Calc displays 3 May 2014 (current year). 
It works with all dates except for:

Input 1/4 (for 1 April 2014): Calc displays 1/4. 
Input 3/4 (for 3 April 2014): Calc displays 3/4. 
Input 1/2 (for 1 Feb 2014): Calc displays 1/2. 

I haven't tested each and every date but the above are the most obvious ones.

Thanks,
Uli
Comment 1 stragu 2014-04-29 12:59:35 UTC
I can confirm this with 4.1.5.3
You pointed out the three auto-correct replacements for fractions (accessible in Tools > AutoCorrect option > Replace tab).

It is indeed unintuitive in the case of cells already formatted for dates.

There are temporary workarounds if the fractions are not useful to you:
- In the AutoCorrect options, delete the three replacements that you pointed out;
- Or deactivate the replacement table in the Options tab.

To the developpers: is it possible to deactivate particular autocorrect rules for particular formatting cases?
Or better: let the formatting do its job before applying the replacement rules?

Cheers
Comment 2 tommy27 2014-05-02 10:40:05 UTC
already known issue.

*** This bug has been marked as a duplicate of bug 33899 ***