Bug Hunting Session
Bug 78046 - XLSB page set to landscape but shows as portrait
Summary: XLSB page set to landscape but shows as portrait
Status: RESOLVED DUPLICATE of bug 48767
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: XLSX-Sheet
  Show dependency treegraph
 
Reported: 2014-04-28 20:19 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-09-29 12:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
the page format dialog (49.80 KB, image/png)
2014-04-28 20:19 UTC, Yousuf Philips (jay) (retired)
Details
the sample xlsb in question (133.57 KB, application/vnd.ms-excel.sheet.binary.macroEnabled.12)
2014-06-28 15:36 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-04-28 20:19:15 UTC
Created attachment 98140 [details]
the page format dialog

I opened an xlsb file sent to me from a friend and when i compared its pdf output in LibO 4.2 to word 2010, i noticed that it is supposed to be in landscape, but LibO is showing it in portrait.
Comment 1 Yousuf Philips (jay) (retired) 2014-04-28 20:21:29 UTC
forgot to mention, it was tested on 3.6 to 4.3
Comment 2 Yousuf Philips (jay) (retired) 2014-04-28 20:24:27 UTC
i also converted the file from word 2010 into xlsx, xls, and ods formats and it was landscape in xlsx and xls but portrait in ods.
Comment 3 Florian Reisinger 2014-06-28 12:54:38 UTC
Do we have a test doc? [What is xlsb?]
Comment 4 Yousuf Philips (jay) (retired) 2014-06-28 15:36:01 UTC
Created attachment 101927 [details]
the sample xlsb in question

http://filext.com/file-extension/XLSB
Comment 5 Florian Reisinger 2014-06-28 17:20:32 UTC
Conformed with Version: 4.4.0.0.alpha0+
Build ID: bdd87b2acddb2e244569dcc8f228e270614dc59e
TinderBox: Win-x86@39, Branch:master, Time: 2014-06-23_00:37:24
Comment 6 QA Administrators 2015-07-18 17:42:42 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2015-10-16 19:34:32 UTC
Still confirmed.
Workaround is to change the orientation in printer settings, so changing severity to minor.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 186f32f63434e16ff5776251657f902d5808ed3d
TinderBox: Win-x86@39, Branch:master, Time: 2015-10-16_09:42:47
Locale: en-US (fi_FI)
Comment 8 Bartosz 2016-07-31 21:48:49 UTC

*** This bug has been marked as a duplicate of bug 48767 ***