Download it now!
Bug 78058 - "Apply" Page Margins button sometimes doesn't work
Summary: "Apply" Page Margins button sometimes doesn't work
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-29 04:54 UTC by Jake
Modified: 2015-06-21 17:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jake 2014-04-29 04:54:16 UTC
When apply new margins to a page via Format > Page...

Sometimes the "Apply" button does not work. Specifically when using it multiple times, in the same window instance. By not working, I mean the margins do not get set. This can be proved by closing the window instance after attempting to set the margins multiple times, and reopening it, to see the actual margins.

Also, when changing margins, painting errors occur at the edges of the document (wasn't sure to file this as a separate bug or not)
Comment 1 tommy27 2014-05-02 13:23:33 UTC
reworded summary notes since original descritption was too generic.

by the way have you tried upgrading to stabler 4.1.6.2 final release or try newer 4.2.3.3?
Comment 2 Yousuf Philips (jay) (retired) 2014-05-29 06:59:26 UTC
Confirmed in Linux Mint in 4.1.6 and 4.2.6. Its doesnt occur in 4.2.4 and 4.3 beta.

To Reproduce:
1. Open Writer
2. Goto Menu > Format > Page... > Page [tab]
3. Change left and right margin value a frist time and click apply
4. Change left and right margin value a second time and click apply
5. Change left and right margin value a third time and click apply
6. The third apply values wont be processed.

This is similar to bug 78342.
Comment 3 QA Administrators 2015-06-08 14:41:39 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.3 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results;
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-06-08
Comment 4 Buovjaga 2015-06-21 17:47:45 UTC
(In reply to Yousuf (Jay) Philips from comment #2)
> Confirmed in Linux Mint in 4.1.6 and 4.2.6. Its doesnt occur in 4.2.4 and
> 4.3 beta.
> 
> To Reproduce:
> 1. Open Writer
> 2. Goto Menu > Format > Page... > Page [tab]
> 3. Change left and right margin value a frist time and click apply
> 4. Change left and right margin value a second time and click apply
> 5. Change left and right margin value a third time and click apply
> 6. The third apply values wont be processed.
> 
> This is similar to bug 78342.

No problem anymore. WFM.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)

Ubuntu 15.04 64-bit 
Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-06-20_00:06:19
Locale: en-US (en_US.UTF-8)