Download it now!
Bug 78342 - Cannot apply changes to index paragraph after clicking Apply button in dialog
Summary: Cannot apply changes to index paragraph after clicking Apply button in dialog
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-06 14:20 UTC by a3086477
Modified: 2016-04-25 17:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description a3086477 2014-05-06 14:20:28 UTC
A) Steps to take
1. Type various paragraphs
2. Assign H1, H2 styles to some paragraphs
3. Insert Table of Contents index
4. Right-click on entry in ToC and select Edit Paragraph Style... command from context menu
5. In Paragraph Style dialog make a change and click Apply
6. Make another change and click Apply, such as 'undoing' the change just made by selecting the previous option

B) What happens
After step 5 the change is applied as expected, after step 6 nothing happens. One has to close the dialog, open it again, and then make the desired changes.
It is possible to make multiple changes and submit all by clicking Apply.

C) What should happen
After making a change and clicking Apply apply the currently selected settings. Allow for repeating this as often as desired without having to close and reopen the dialog
Comment 1 Yousuf Philips (jay) (retired) 2014-05-29 01:19:21 UTC
Confirmed in 3.6.7, 4.1.6, 4.2.4 and 4.3 beta on Linux Mint.
Comment 2 Octavio Alvarez 2015-03-13 22:43:46 UTC
Confirmed in 4.4.1.2.
Comment 3 tommy27 2016-04-16 07:23:06 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 4 Octavio Alvarez 2016-04-22 00:56:47 UTC
Can't reproduce on 5.1.1.2 under Ubuntu 14.04. Can somebody else try to reproduce it? Is it fixed for everyone or just for me?

This is possibly related to bug #88342 which also appears fixed to me.
Comment 5 Yousuf Philips (jay) (retired) 2016-04-25 17:58:29 UTC
Seems fixed to me.

Version: 5.2.0.0.alpha0+
Build ID: b19ac3c4c6b4a41a1f3acac68b299fd676428a87
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-04-21_08:41:08
Locale: en-US (en_US.UTF-8)