Bug 78151 - FORMATTING: Not possible to format auto layout text - it's locked to outline style
Summary: FORMATTING: Not possible to format auto layout text - it's locked to outline ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: BSA target:4.3.0 target:4.2.5 target:...
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-01 12:57 UTC by Máirín Duffy
Modified: 2014-12-03 13:26 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
This sample slide deck documents the problem pretty well. (30.03 KB, application/vnd.oasis.opendocument.presentation)
2014-05-01 13:02 UTC, Máirín Duffy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Máirín Duffy 2014-05-01 12:57:47 UTC
Problem description: 

I've created a screencast to demonstrate this issue here:
https://www.youtube.com/watch?v=NgKjpVtqB5Y

A specific use case that this bug prevents is styling the autolayout text on a master slide to automatically be left-aligned, no bullets, no indent, such that when a user creates a new slide using that slide master, when they start typing in the slide it will not be left-aligned, no bullets, no indent.

There is no possible way to achieve this, currently. To give the slides the look you want today, you basically have to run through every single slide connected to that master and manually restyle the text, slide-by-slide.

It appears that the autolayout text box on master slides is locked to the 'Outline N' (where N is 1-10 I guess) style in the styles and formatting box. I've tried a number of different ways to reset that so it used the 'Notes' or 'Text' style to no avail.

I have also tried deleting the autolayout text box to make a plain text box and styling that, but it is not possible to delete to autolayout text box. The other problem with that, of course, is that the text could only be edited on the master and would propagate across all slides - it just doesn't solve the problem of styling the text for template end-users. 

This bug lessens the value of master slides because it severely limits the style choices a designer creating a template can make with the template users.

Steps to reproduce:

1. Create a new slide deck in Impress.

2. Go to the slide master and try to change the text block in the master slide to a non-outline style. Try removing the bullets by turning off bulleting. Try deleting the text.

3. Close the slide master and create a new slide using that slide master.

4. See how as soon as you add text to your new slide, it's given a bullet and indent even though you removed that in the master.

Expected behavior:

I would expect to be able to apply styles from the styles & formatting tool to the autolayout text on a slide master, and to have any slides created using that master inherit that style in their text. 

When I remove the bullets from the master slide sample text in the autolayout text block, I expect that change to stick, and I don't expect - when using that master slide to create a new slide - for the text on that new slide to be bulleted and indented.

              
Operating System: Fedora
Version: 4.2.3.3 release
Comment 1 Máirín Duffy 2014-05-01 13:02:56 UTC
Created attachment 98291 [details]
This sample slide deck documents the problem pretty well.
Comment 2 Máirín Duffy 2014-05-01 13:08:06 UTC
Just a note - if you select the AutoLayout text and set bullets to have 'no bullet' - that style does propagate to slides using that master, but this doesn't remove the indent and I can't figure out how to get rid of the indent. Sure, you could shift the autolayout text box in the master to the left to account for it, but that's a bit hacky.

The other thing is it would be really nice to be able to take advantage of styles and formatting here, so you could simply apply a style to take care of the bullet removal, fonts, colors, etc. rather than having to do that manually. You could change say the font in the outline styles, yes - but then all master slides would be stuck with that color, wouldn't they, since it's linked to the outline style and all the autolayout text is locked to the outline style?
Comment 3 Caolán McNamara 2014-05-14 15:41:08 UTC
So, here's a video of how to achieve what you want to do with the current UI.
http://youtu.be/Guqjv_uKadA

Here's what I think we could do (without looking into the implementation details to see if thats plausible yet).

1. In the master slide view modify it so that any changes in formatting to the preview is automatically synced up to the outline level style. So formatting an outline level 2 preview changes outline level 2 style
2. Disallow changes to the preview which aren't logical, e.g. can't delete a paragraph from it, can't insert a paragraph, etc. Seeing as we aren't currently supporting custom text for the click-here to edit, disallow changing the text two and automatically select the entire paragraph and not allow partial selections of the paragraph.

caolanm->thb: Does this sound plausible to you ? Why do we currently allow these to be edited in the master view at the moment ?
Comment 4 Thorsten Behrens (CIB) 2014-05-14 19:58:56 UTC
(In reply to comment #3)
> caolanm->thb: Does this sound plausible to you ? Why do we currently allow
> these to be edited in the master view at the moment ?
>
Yep. And I think the exact reasons are lost in history. ;)
Comment 5 Máirín Duffy 2014-05-14 23:05:34 UTC
Hi Caolán - I think another issue here is the styles & formatting dialog. It isn't functional in master view yet is active and clickable while in master view as if it *should* do something. Until some form of custom fields is possible in the master view, it might make sense to grey that out while in master view as well?
Comment 6 Commit Notification 2014-05-20 11:39:59 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=52871279e9811d437ebe881e30b6c76208c84e65

Related: fdo#78151 fix 'pIds unsorted' warning



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-05-20 11:40:15 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=27fc60874795849b43903f27076e9dcafb958c76

Related: fdo#78151 disable promote or demote outline levels in master view



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2014-05-21 08:40:00 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bbbe324de18d0032be12918ea55fb43f051c10a4&h=libreoffice-4-2

Related: fdo#78151 fix 'pIds unsorted' warning


It will be available in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Joel Madero 2014-05-21 15:44:55 UTC
Apparently this is at least confirmed. Marking as NEW, I'll leave it to Caolan to close the bug as fixed.
Comment 10 Commit Notification 2014-06-09 08:25:15 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7e600aca08ebbd69b0c8ef924c84af4dcf80df56

Related: fdo#78151 force outliners in master view to be read-only text



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2014-06-13 16:07:53 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8a5b3971057237b178f7e65437deec766b56f9c4

Resolves: fdo#78151 change style on toggling bullets on master page outliners



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Caolán McNamara 2014-06-13 16:14:58 UTC
Right, I'll write up something a bit longer for the release notes, but the summary is that 

+ the text of these things in master view is now read-only which removes that confusion where deleting things caused them to magically reappear
+ because they are read-only now, to show/hide levels you right click on the last outline entry and "show next"/"hide this" it
+ and clicking the toggle bullet button now, when in this master view, toggles the button off the correct level of the underlying style, so the changes affect the normal view, instead of uselessly toggling the numbering on/off the paragraph preview of the style and leaving the actual style untouched.

I'd still like the have the paragraphs completely "selected", i.e. only full paragraphs can be selected at a time, but at the moment the selection colour is xor inverse which looks horrible, so ideally we rework that to use the standard selection colours.
Comment 13 Commit Notification 2014-12-03 10:53:06 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f8533123802c5a709280dd06b4452d00a11c71b1

Related: fdo#78151 only make outline, title and subtitle read-only

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2014-12-03 10:54:26 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8ee17eb341aaa4285d6a1fb6cdb54214379b63ec&h=libreoffice-4-4

Related: fdo#78151 only make outline, title and subtitle read-only

It will be available in 4.4.0.0.beta2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Cor Nouws 2014-12-03 11:30:50 UTC
Hi Máirin,

(In reply to Máirín Duffy from comment #5)
> Hi Caolán - I think another issue here is the styles & formatting dialog. It
> isn't functional in master view yet is active and clickable while in master
> ..

For me in 4.2.7 any way, the view in Styles and Formatting does follow the outline style. Both in master age and normal view. Both the separate Styles and Formatting, and that one in the Side bar.. And changes I make are visible...
Comment 16 Caolán McNamara 2014-12-03 13:26:07 UTC
caolanm->cor: In master view its still not 100% clear that the styles in the browser are effectively another view of the master elements, or vice versa. To make that clearer, the blocker problem is that there should be "something" that matches every style and right now the "subtitle" style doesn't get a preview box. Ideally we should have 2 preview slides per master page, the "first" title slide with title and subtitle and the other as the "following" page with outlines.

Given a preview of everything then clicking on a style in the style browser in master mode could make us warp directly to the matching element making it clearer the connection between the two and making it clear that you cannot e.g. apply a subtitle style to an outline.