Download it now!
Bug 78175 - Changing paragraph style does not change first line indent
Summary: Changing paragraph style does not change first line indent
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc, filter:docx
Depends on: 114287
Blocks: DOCX-Paragraph DOCX-Bullet-Number-Outline-Lists DOC-Paragraph Paragraph-Indent
  Show dependency treegraph
 
Reported: 2014-05-02 06:51 UTC by Oliver
Modified: 2018-07-30 16:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
4 paragraphs in "Corps de texte" style, indenting will not change when style is changed (12.38 KB, application/vnd.oasis.opendocument.text)
2014-05-02 06:51 UTC, Oliver
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver 2014-05-02 06:51:03 UTC
Created attachment 98325 [details]
4 paragraphs in "Corps de texte" style, indenting will not change when style is changed

To repeat the problem, use the following steps on the attached document : 
* check the paragraph format of the lines in the attached document (should be all the same) : indenting before text (I'm translating from the French "Retrait avant le texte", first box on the first tab) is 0.76, after the text 0.0 and first line -0.76
* the paragraphe style is "Corps de texte" (at least in my French version)
* select all lines and chose a different paragraph style from the drop down list, e.g. the default style : one can see that some things change e.g. the spacing between the paragraphs, however the indenting does not change
* if one checks the paragraph format, indenting before text is still 0.76, first line -0.76, even though the default style has no indenting.
Comment 1 Cor Nouws 2014-05-02 07:45:29 UTC
Hi Brendel,

thanks for reporting. I can confirm the problem. Also in 4.2.4.1

Also note that Format > Clear formatting does not change the indent of the paragraphs to the setting of the style. Weird

Any idea where that text is from?
Comment 2 Jean-Baptiste Faure 2014-05-02 20:45:48 UTC
The text comes from a .doc file. Indeed there is a numbering style associated to the paragraphs. An this numbering style is named WW8Num1 (WW8 -> WinWord 8).
To remove the numbering do the following:
- select the 4 paragraphs
- Format > Paragraph
- go to tab "Outline & Numbering" ("Plan & numérotation" for a UI in French)
- in the Numbering style dropdown choose "None" and click the OK button

Not sure if there is a bug here.

Best regards. JBF
Comment 3 Oliver 2014-05-03 13:31:47 UTC
Hello, 
yes, these paragraphs were probably copied from a .doc or a .docx document. I don't think that I did cope/paste directly a numbered list, but this might have been hidden in an empty paragraph mark. 
I still think that this is a bug : when I change the paragraphe style using the drop down list, the numbering style is quite clearly included in the paragraph style definition. So when I change to a style that has "no" numbering style defined, it should be cleared. Same thing for "clear format" which I think has been added to get rid of all formatting. I think that the numbering style is just to checked when a style change occurs or cleared when "clear format" is done. 
Cheers

Oliver
Comment 4 QA Administrators 2015-06-08 14:41:25 UTC Comment hidden (obsolete)
Comment 5 Cor Nouws 2015-06-08 18:17:13 UTC
(In reply to brendel from comment #3)
> Hello, 
> yes, these paragraphs were probably copied from a .doc or a .docx document.
> I don't think that I did cope/paste directly a numbered list, but this might
> have been hidden in an empty paragraph mark. 
> I still think that this is a bug : when I change the paragraphe style using
> the drop down list, the numbering style is quite clearly included in the
> paragraph style definition. So when I change to a style that has "no"
> numbering style defined, it should be cleared. Same thing for "clear format"
> which I think has been added to get rid of all formatting. I think that the
> numbering style is just to checked when a style change occurs or cleared
> when "clear format" is done. 

There is some preference in settings around numbering, that, IIRC, makes the indent of numbering applied to a paragraph. And to remove that, it is needed to explicitly remove the numbering with Ctrl-Shft-F12 (or icon Numbering on/off)
Comment 6 QA Administrators 2016-09-20 10:00:16 UTC Comment hidden (obsolete)
Comment 7 Oliver 2016-09-23 15:20:09 UTC
The problem is still the same in the version that I have installed in the moment : Version: 5.1.4.2

Even if this problem is perhaps based on a copy paste that gives a strange paragraphe style, at least the "clear all" command should clear all formatting, but it is clearly not removing the first line indent. 

Cheers

Oliver
Comment 8 Regina Henschel 2017-12-09 15:56:55 UTC
There are some problems about the relation ship between indent by list and indent by paragraph. I track that in bug 114287.
Comment 9 Timur 2018-07-30 16:42:08 UTC
> I still think that this is a bug : when I change the paragraphe style using
> the drop down list, the numbering style is quite clearly included in the
> paragraph style definition. So when I change to a style that has "no"
> numbering style defined, it should be cleared. 
No, list style was applied directly and it remains. You may test with a new document. 

"Changing paragraph style does not change first line indent" is a consequence. 
This could've been a bug "numbering style text is not marked as numbering". If user doesn't pay attention to WW8Num1.
But an example may be the result of some old bug in LO, who knows. 

We can't know because we don't have reproducible steps. So I close as Invalid. 
It's not probable that someone will go into this to fix.