Bug 78277 - FORMATTING: Frame Transparency lost during save/reload
Summary: FORMATTING: Frame Transparency lost during save/reload
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-05-05 06:21 UTC by Jim Avera
Modified: 2014-10-18 11:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2014-05-05 06:21:07 UTC
If a text Frame is created with a background color and Transparency set to a value greater than 0%, then saving and reloading the document make the frame non-transparent, i.e., the transparency setting seems to not be saved.

This is a REGRESSION since 4.2 (the UI is different in 4.2 where transparency is set in the Background tab, whereas in 4.3 there are separate Area and Transparency tabs in the edit-Frame dialog).

Steps to reproduce:
1. In a text doc, select some text and do Insert->Frame, OK
2. Select the frame, Rightclick->Frame... set Area to a dark background color and Transparency to 90%.
3. Save; Reload

Current behavior: The frame returns to opaque status

Expected behavior: Transparency setting should be preserved

              
Operating System: Ubuntu
Version: 4.3.0.0.alpha1
Comment 1 Jorendc 2014-05-05 17:43:10 UTC
Looks like a dupe of bug 77723 to me, therefore I'll mark it as such. Please retest using a more recent version of our master versions (which you can download here: http://dev-builds.libreoffice.org/daily/master/

If you still can reproduce this bug, with a version newer then 2014-04-27 , please feel free to mark this bug again as UNCONFIRMED.

Kind regards,
Joren

*** This bug has been marked as a duplicate of bug 77723 ***
Comment 2 Jim Avera 2014-05-05 19:13:36 UTC
The bug is still there in 4.3.0.0.alpha1+ 2014-05-03_23:16:33
Build ID: 20778b037c688759a4dc46acb8aeb66c9d1290cc
Linux amd64

Setting status back to UNCONFIRMED
Comment 3 tommy27 2014-05-05 21:39:33 UTC
confirm regression in 4.3.0.0.alpha1+ under Win7x64
Build ID: f76026a43acc65465882924796d93e635c35fd90
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-04_06:34:33

works fine in 4.2.3.3

status NEW. platform ALL.
Comment 4 Joachim Wiedorn 2014-10-18 10:59:06 UTC
My version : 4.3.2.2 on GNU/Linux Debian

This version don't lose the transparency.

It's fine (beside the 100% problem of
https://bugs.freedesktop.org/show_bug.cgi?id=83963
Comment 5 tommy27 2014-10-18 11:47:25 UTC
I confirm it works fine with LibO 4.3.2.2 under Win7x64.
I set status to RESOLVED WORKSFORME