Bug 78278 - FORMATTING: Frame background color can not be set during initial creation, only when editing
Summary: FORMATTING: Frame background color can not be set during initial creation, on...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-05-05 06:25 UTC by Jim Avera
Modified: 2015-12-15 10:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2014-05-05 06:25:47 UTC
Problem description: When creating a text Frame, in the Area tab, if the Fill drop-down is set to "Color", then some sub-windows appear where the color-picker should be, but there is no color-picker, just white space.  You can not select a color.

If an existing frame is edited, however, the color-picker appears as expected.

Steps to reproduce:
1. Open new text doc
2. Insert-Frame, click Area tab 
3. Change the Fill drop-down to Color

Current behavior: Empty sub-windows appear

Expected behavior: Color picker should appear
              
Operating System: Ubuntu
Version: 4.3.0.0.alpha1
Last worked in: 4.2.2.1 release
Comment 1 Jacques Guilleron 2014-05-05 21:54:13 UTC
Hello Jim,

I confirm this with LO 4.3.0.0.alpha1+
Build ID: 0b03f7ed575838f90e6b1ebec3538a3a214f81fb
TinderBox: Win-x86@39, Branch:master, Time: 2014-04-30_01:30:46
& Windows 7 Home Premium.

Jacques
Comment 2 Jean-Baptiste Faure 2014-07-06 15:49:43 UTC
Not reproducible for me with Version: 4.3.1.0.0+
Build ID: b1d4fbb69491bcf211fb4c8cb5c2dd4d9efb4edb under Ubuntu 14.04 x86-64

Could this bug have been fixed by commit http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-3&id=dc17dad5fd7509f191718df8690e5847ab87669a ?

Best regards. JBF
Comment 3 Jacques Guilleron 2014-07-07 19:53:43 UTC
Neither for me with LO 4.3.1.0.0+
Build ID: 3c67e7dae5041122da02b3b181fcf783d46e6a34
TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-07-05_14:16:20
& Windows 7 Home Premium.
@ Jean-Baptiste: This seems to be the old way to set frame parameters, with no change, so we can think so. master~2014-07-06_00.19.58_LibreOfficeDev_4.4.0.0.alpha0 is like 
LO 4.3.0.0.alpha1+
So this commit has probably fixed also this bug.
Thank you for info.
 
I set Status to WORKSFORME, but I don't know if this the right tag.

Regards,
 
Jacques
Comment 4 Robinson Tryon (qubit) 2015-12-15 10:55:03 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]