Download it now!
Bug 78289 - EDITING: cursor blinks at wrong place: 1 letter wrong or in the middle of a letter & last letters of a phrase may not show
Summary: EDITING: cursor blinks at wrong place: 1 letter wrong or in the middle of a l...
Status: RESOLVED DUPLICATE of bug 48402
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-05 09:24 UTC by Sven AERTS
Modified: 2014-06-04 15:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
cursor is blinking in the letter instead of between letters and after erasing, the space is not erased yet the last letter of the first word = mismatch of 1 place of where the cursor is blinking (78.25 KB, image/png)
2014-05-05 09:24 UTC, Sven AERTS
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sven AERTS 2014-05-05 09:24:16 UTC
Created attachment 98462 [details]
cursor is blinking in the letter instead of between letters and after erasing, the space is not erased yet the last letter of the first word = mismatch of 1 place of where the cursor is blinking

Problem description: 

Steps to reproduce:
1. type 2 words or small phrase
2. place your cursor between two letters
3. try to erase a specific space or a character

Current behavior:
1. you'll notice the cursor is blinking in the letter instead of between letters. cf. Screenshot 2014-05-05 11.18.31
2. you'll notice you'll always erase 1 or 2 letters AFTER/BEHIND where the cursor is blinking. cf Screenshot 2014-05-05 11.18.54: the cursor is blinking after the space between the 2 words. You'd expect it erasing the space, yet it erased the last letter of the first word.
3. I also notice the last letter in the phrase is not showing.  Changing zoom may help.

Expected behavior:
you'd expect the blinking cursor between letters and erase the letter just in front
Operating System: Mac OS X
Version: 4.2.1.1 release
Comment 1 Yousuf Philips (jay) (retired) 2014-05-29 04:39:00 UTC
Cant reproduce in Linux Mint, so it maybe a Mac OS X issue.
Comment 2 Alex Thurgood 2014-06-04 14:08:28 UTC
Confirming, and it is really annoying, making LO virtually unusable.

However, I will have to see whether or not his is a dup.

Alex
Comment 3 Alex Thurgood 2014-06-04 15:39:07 UTC
Seems like dup of 48402, a very old, and as yet unresolved bug. However, given that LO uses a deprecated API on the Mac for text rendering, and the new stuff is only partially implemented, not really surprising.

*** This bug has been marked as a duplicate of bug 48402 ***