Bug 78340 - graphite fonts change rendering when "Nonprinting Characters" is enabled
Summary: graphite fonts change rendering when "Nonprinting Characters" is enabled
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.3.0
Keywords:
Depends on: HarfBuzz
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-06 13:48 UTC by Michael Stahl
Modified: 2016-11-06 18:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document (13.75 KB, application/vnd.oasis.opendocument.text)
2014-05-07 11:18 UTC, László Németh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Stahl 2014-05-06 13:48:20 UTC
for this bugdoc from bug 70666:
https://bugs.freedesktop.org/attachment.cgi?id=87870

the rendering changes quite substantially when the Nonprinting Characters
button is pressed: letters disappear, and the diacritic marks below the
red letters disappear or move around.

the problem happens at least since OOo 3.2, got worse in LO 3.4 - LO 4.2,
and appears somewhat less bad on master (only diacritics disappear),
so i'm not sure to what extent this qualifies as a regression...
Comment 1 László Németh 2014-05-07 11:16:34 UTC
I can reproduce the problem only with an explicit SAL_GRAPHITE_CACHE_SIZE:

Tested with the attached file (a reduced version of the file sent by Gellért Gyuris).

export SAL_GRAPHITE_CACHE_SIZE=512
soffice # bad
export SAL_GRAPHITE_CACHE_SIZE=
soffice # good

Warning! The Graphite extension set SAL_GRAPHITE_CACHE_SIZE in the .profile under Linux. (I had a lot of problems with it, reporting a few false alarms to Martin, because I didn't know about it.)
Comment 2 László Németh 2014-05-07 11:18:00 UTC
Created attachment 98616 [details]
Test document
Comment 3 László Németh 2014-05-07 14:08:54 UTC
Gellért found a similar SAL_GRAPHITE_CACHE_SIZE definition in his old .profile, (he used the Graphite extension and its cache settings). His newly installed Linux has no Graphite problems.
Comment 4 QA Administrators 2015-06-08 14:41:27 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2016-09-20 10:00:19 UTC Comment hidden (obsolete)
Comment 6 Khaled Hosny 2016-09-21 07:50:03 UTC
I can’t reproduce this on Linux.
Comment 7 Michael Stahl 2016-09-21 10:08:00 UTC
the situation has much improved since 4.2, but i'm still seeing changes...

* there are big improvements in 4.3.7 vs. 4.2.8
* then in 5.0.6 i see no change between non-printing characters on/off
  but the rendering looks flawed in both modes as i don't think the
  dotted red circles belong
* then 5.1.5/current 5.2/current master are rather good but there
  are still some small changes in the diacritic marks when toggling NP chars:
  - some "underlines" move up to the baseline
  - one mark in the 4th line from the bottom moves from "upper right corner"
    down to the baseline
  - there is a very tiny change in horizontal positioning (kerning?)
    of some of the glyphs

btw this is all with the GodaGr.ttf file that was attached at bug 70666:
https://bugs.documentfoundation.org/attachment.cgi?id=87871
Comment 8 Khaled Hosny 2016-09-23 15:11:50 UTC
OK, I see the sight layout difference. The good news is that bug 89870 fixes it.