Download it now!
Bug 78357 - FILEOPEN: RTF - Hyperlinks exported with black underline
Summary: FILEOPEN: RTF - Hyperlinks exported with black underline
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard:
Keywords: filter:rtf
Depends on:
Blocks: RTF Hyperlink
  Show dependency treegraph
 
Reported: 2014-05-06 20:28 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-09-29 21:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
shows how the file looked before saving as an RTF and afterwards (31.60 KB, image/jpeg)
2014-05-06 20:28 UTC, Yousuf Philips (jay) (retired)
Details
zoomed in blue link with black underline (50.82 KB, image/jpeg)
2014-05-07 09:48 UTC, Yousuf Philips (jay) (retired)
Details
minimal test case to save as .rtf (9.71 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-05-07 14:51 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-05-06 20:28:56 UTC
Created attachment 98584 [details]
shows how the file looked before saving as an RTF and afterwards

I download the .docx file found at < http://download.microsoft.com/documents/uk/partner/publicsector/DraftMicrosoftResponsetoGovernment.docx > and opened it in LibO and saved it as an RTF. Then i reopened the RTF file and all links had black underlines rather than blue. This was tested in Linux Mint on the last releases from 3.6 to 4.2 and 4.3 alpha. Its a fileopen problem as the same RTF file opened in word 2010 has the links with blue underlines.
Comment 1 tommy27 2014-05-07 04:01:28 UTC
double check your screenshot. I see blue underlines in both images.
Comment 2 Yousuf Philips (jay) (retired) 2014-05-07 07:32:16 UTC
double checked the screenshot and the top one is dark blue and the bottom is black.
Comment 3 tommy27 2014-05-07 08:21:01 UTC
so check your monitor color-settings :-)

I confirm "Unicode 6.2" text is bold blue underlined in both images and I cannot spot significant color difference between .docx and .rtf

only differences I see is that not underlined text is grey, bold, italic in .docx
while is bold black in before "unicode 6.2" and no-bold, no-italic, black in .rtf
Comment 4 Yousuf Philips (jay) (retired) 2014-05-07 09:46:47 UTC
(In reply to comment #3)
> so check your monitor color-settings :-)
> 

you should have said for me to check my eyes as monitors cant change underline colors. :)

> I confirm "Unicode 6.2" text is bold blue underlined in both images and I
> cannot spot significant color difference between .docx and .rtf
> 
> only differences I see is that not underlined text is grey, bold, italic in
> .docx
> while is bold black in before "unicode 6.2" and no-bold, no-italic, black in
> .rtf

already submitted bugs for the color issue (bug 78313). :)
Comment 5 Yousuf Philips (jay) (retired) 2014-05-07 09:48:31 UTC
Created attachment 98609 [details]
zoomed in blue link with black underline
Comment 6 tommy27 2014-05-07 09:55:37 UTC
ok now I see it!!! 

first screenshot was to small and my eyes are not so good as yours!!! :D

issue confirmed under Win7x64 using 4.2.3.3
Comment 7 Yousuf Philips (jay) (retired) 2014-05-07 14:21:02 UTC
would have thought you'd try out the steps in the initial summary to see if worked there an not really just on my screenshots. :)
Comment 8 tommy27 2014-05-07 14:28:30 UTC
my bad :-)
Comment 9 tommy27 2014-05-07 14:51:46 UTC
Created attachment 98628 [details]
minimal test case to save as .rtf
Comment 10 Yousuf Philips (jay) (retired) 2014-05-07 14:59:53 UTC
i normally do upload files created by other software (kingsoft, word, etc) encase the team doesnt have that software on their pc, but as its all LibO, i didnt see the advantage of doing that as well.
Comment 11 tommy27 2014-05-07 15:06:26 UTC
I think a minimal test case is easier and faster to use to reproduce the bug, rather than scrolling a multipage document looking for the exact point where the issue is.
Comment 12 tommy27 2014-05-07 15:48:43 UTC
also remember that external hyperlinks may change or expire, so it's alway good practice to upload documents in bugzilla, removing unnecessary parts.
Comment 13 Yousuf Philips (jay) (retired) 2014-05-07 18:24:19 UTC
someone on the mailing mentioned that it would be best to upload these files as well but i told them all my test .docx files were from documents on microsoft's website, which isnt going anywhere. :)
Comment 14 Urmas 2014-08-06 12:56:16 UTC
\ulc0 keyword is interpreted as 'black', not as 'the font color'. Also it is the default value which doesn't have to be exported at all.
Comment 15 Robinson Tryon (qubit) 2015-12-10 01:08:32 UTC Comment hidden (obsolete)
Comment 16 Miklos Vajna 2016-05-13 20:02:06 UTC
I've fixed this with commit 76c0d0abc89cd8948706083c2660b71a2dad670c on 2014-09-07 in 4.4 (4.3 was still bad).
Comment 17 Marina Latini (CIB) 2016-05-16 16:46:12 UTC
Verified fixed:

Version: 4.4.7.2
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: it_IT.UTF-8
OS: openSUSE Tumbleweed (20160422) (x86_64)

Version: 5.1.3.1
Build ID: 10m0(Build:1)
Thread CPU: 4; Versione SO: Linux 4.5; Resa interfaccia: predefinito; 
Locale: it-IT (it_IT.UTF-8)
OS: openSUSE Tumbleweed (20160422) (x86_64)