Bug Hunting Session
Bug 78397 - "%mu" doesn't insert "mu" symbol
Summary: "%mu" doesn't insert "mu" symbol
Status: RESOLVED DUPLICATE of bug 32415
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-07 15:17 UTC by Ander
Modified: 2014-05-20 15:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
%mu doesn't insert μ symbol, in the example doesn't work (70.29 KB, image/png)
2014-05-07 15:17 UTC, Ander
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ander 2014-05-07 15:17:38 UTC
Created attachment 98631 [details]
%mu doesn't insert μ symbol, in the example doesn't work

"%mu" doesn't insert "mu" symbol --> "μ"

In the example doesn't work.
Comment 1 Julien Nabet 2014-05-08 20:39:30 UTC
On pc Debian x86-64 with 4.2 sources updated several days ago, I don't reproduce this problem.
For the test, could you give a try to 4.2.4?
Comment 2 Ander 2014-05-08 20:54:02 UTC
I'm in arch linux, libreoffice 4.2.4 currently is in testing repo but in a few days it will be available and I will do the test.
Comment 3 Ander 2014-05-09 22:13:40 UTC
Tested with libreoffice 4.2.4. Same result, "%mu" doesn't insert "μ" symbol, and in the formula examples instead of "μ" it shows "%mu".
Comment 4 Julien Nabet 2014-05-09 22:17:56 UTC
Thank you for your feedback.

Did you install any LO specific extensions?
Did you install any fonts?
Has it ever worked on your machine?

Could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux) and give it a new try?
Comment 5 Ander 2014-05-09 22:26:47 UTC
Did you install any LO specific extensions?
- No.

Did you install any fonts?
- I installed those google-fonts https://github.com/w0ng/googlefontdirectory


Has it ever worked on your machine?
- Never.

Could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux) and give it a new try?
- I've done it but I have the same result.
Comment 6 Ander 2014-05-09 22:41:58 UTC
And microsoft's fonts too.
Comment 7 Regina Henschel 2014-05-10 12:49:47 UTC
Please start Math. Open the Catalog (Tools > Catalog). Select the symbol set "Greek". Is the symbol µ listed there? If yes, click on it and look, what characters are shown below. It might be, that it differs from what you expect. Same with symbol set iGreek.

If the symbol µ is missing, you can add it with button Edit in that dialog.
Comment 8 Ander 2014-05-10 13:25:46 UTC
Ok "mu" symbol is insert with "%my" or "%imy".

But if this is the way to insert that symbol, why is in the formula examples "%mu" which even in te example doesn't work?
Comment 9 Regina Henschel 2014-05-10 13:43:20 UTC
The characters which are used by % are language dependent. They are matter of translation.
Comment 10 Thomas Arnhold 2014-05-20 15:58:36 UTC
The symbol names are unhappily language dependent at the moment.

*** This bug has been marked as a duplicate of bug 32415 ***