Download it now!
Bug 78413 - EDITING: Pasted object position differs half the amount of the border width
Summary: EDITING: Pasted object position differs half the amount of the border width
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-05-08 00:02 UTC by pafal
Modified: 2014-05-21 09:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pafal 2014-05-08 00:02:18 UTC
In reaction to the bug hunting session, I have tried the very long term bugs still present in OO/LO. This (originally 45260) is one of them. Using the release version 4.2.2.1, this bug appears again! It even does not matter if the border thickness is greater than or equal to zero:

- start LO
- draw a rectangle
- select it
- ctrl+c
- ctrl-v (the copied object becomes selected)
- check position and size (both position coordinates are at 0.01 offset)

Reinstalled to development version 4.2.4.2: it seems there must be nonzero border thickness to reproduce.

This is very annoying in the case you draw some schematics by copy/paste/move using prebuilt blocks...
Comment 1 Cor Nouws 2014-05-08 07:42:41 UTC
thanks for your report Pafal.
I can conform this.
Is OK in 4.1.5.3 > regression
Comment 2 Andras Timar 2014-05-09 20:49:49 UTC
It seems that the hack that fixed bug 45260 is now makes a problem. Possibly the underlying bug was fixed in the meantime. I reverted that commit and it seems that the problem was solved.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=de8f5f2af78877bc63b462195ce63341f6ba7817
Comment 3 pafal 2014-05-21 09:12:08 UTC
Thank you.
Trying the 4.2.5.0.0+ development shows expected behaviour!