Download it now!
Bug 78481 - Wrong rendering of RTF document
Summary: Wrong rendering of RTF document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2014-05-09 10:01 UTC by Miguel Guedes
Modified: 2016-04-16 09:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Libreoffice Writer's rendering of the RTF document (177.85 KB, image/png)
2014-05-09 10:01 UTC, Miguel Guedes
Details
Microsoft Word's rendering of the RTF document (201.10 KB, image/png)
2014-05-09 10:02 UTC, Miguel Guedes
Details
The actual RTF document (238.02 KB, application/rtf)
2014-05-09 10:02 UTC, Miguel Guedes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miguel Guedes 2014-05-09 10:01:39 UTC
Created attachment 98741 [details]
Libreoffice Writer's rendering of the RTF document

Libreoffice Writer renders RTF wrongly. I've attached image file rtf-msw.png showing how the document should be rendered correctly compared to what Libreoffice Writer produces (rtf-low.png).  The actual RTF document used is also attached (document.rtf).
Comment 1 Miguel Guedes 2014-05-09 10:02:16 UTC
Created attachment 98742 [details]
Microsoft Word's rendering of the RTF document
Comment 2 Miguel Guedes 2014-05-09 10:02:40 UTC
Created attachment 98743 [details]
The actual RTF document
Comment 3 Cor Nouws 2014-05-09 11:18:23 UTC
Comment on attachment 98741 [details]
Libreoffice Writer's rendering of the RTF document

correct mime-type
Comment 4 Cor Nouws 2014-05-09 11:21:35 UTC
Thanks Miguel for the issue.

As I can see it, the problem is that the header at the top of page 2 is placed at the bottom of page one in Writer. Is that correct?
Cor
Comment 5 Miguel Guedes 2014-05-09 11:34:41 UTC
Not a problem!

There's a few issues (which I should have really detailed in my OP), namely:

  * The spacing in the top header is off; especially item 1.

  * The comments column on the right (peach) should fill vertically each item-block 1, 2 and 3.
  
  * Comment for item 2.1 overlaps with item 2.2's.

  * Comment for item 3.4 is non-existent.
Comment 6 Miguel Guedes 2014-05-09 11:36:37 UTC
Also, Cor, you may be right in that the heading for item 2 may be wrongly positioned and should instead be following the block on the next page.
Comment 7 A (Andy) 2015-04-06 18:32:06 UTC
In comparison to Comment 5 there are several improvements (these issues are for me no longer reproducible).

But there are still some rendering problems reproducible with LO 4.4.1.2, Win 8.1:
- Heading 1 at the beginning of the comment is not bold
- Page breaks at wrong positions (buggy within the whole document)
- Numbering problems (font characterics of the numbering are not correct: Arial 12 Normal Black instead of Arial 11 Bold Blue), numbering mistake at No. 2 (changed to 3 and a 2 added before) 
- Tick in item 1 of section 4. Declaration is missing
- Missing line break before item "Date" in section 4. Declaration
- In sections 1 to 3 the frames at the end of the comment column is missing
Comment 8 tommy27 2016-04-16 07:23:16 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 9 Miguel Guedes 2016-04-16 09:57:02 UTC
Closing bug as it seems to now be resolved.

Libreoffice v.5.0.5.2
Linux 4.2.0-34-generic #39-Ubuntu SMP
Ubuntu 15.10