Bug 78484 - FILEOPEN: DOCX - Scroll shape not rendered with path attribute of <v:shapetype>
Summary: FILEOPEN: DOCX - Scroll shape not rendered with path attribute of <v:shapetype>
Status: RESOLVED DUPLICATE of bug 41466
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:docx
Depends on:
Blocks: VML-Shapes
  Show dependency treegraph
 
Reported: 2014-05-09 12:03 UTC by Yousuf Philips (jay) (retired)
Modified: 2021-04-13 10:24 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test case file (26.66 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-05-09 12:03 UTC, Yousuf Philips (jay) (retired)
Details
how it looks in word 2007 and LibO 4.2 (157.90 KB, image/jpeg)
2014-05-09 12:03 UTC, Yousuf Philips (jay) (retired)
Details
Minimized test document in docx format (22.03 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-09-08 08:40 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Word and Writer (70.70 KB, image/png)
2020-09-08 08:41 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-05-09 12:03:28 UTC
Created attachment 98749 [details]
test case file

I pulled this test case from a docx file created with word 2007. When i opened the file in word 2007, i see a script styled shape behind the text, but in LibO, i see is a back border around a frame where that shape should appear. Tested on Linux Mint with the latest releases of LibO 3.6 - 4.2 and 4.3 alpha.
Comment 1 Yousuf Philips (jay) (retired) 2014-05-09 12:03:56 UTC
Created attachment 98750 [details]
how it looks in word 2007 and LibO 4.2
Comment 2 tommy27 2014-05-14 02:05:44 UTC
confirmed under Win7x64 using 4.2.4.2 and 4.3.0.0.alpha1+
Build ID: a1dd961c3093f5f7624e4d1f2240e9120fd13f23
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-06_11:47:48
Comment 3 Alexandr 2014-08-14 08:01:28 UTC
Reproducible with LibreOffice 4.4.0.0.alpha0+ Build ID:  4a65e2704ee80701ca750f2e7c8c0565d2aa830 TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-08-04_23:46:59

Hence, it is not a duplicate of bug 70942.
Comment 4 Xisco Faulí 2015-08-19 09:59:48 UTC
This issue is still reproducible with Libreoffice 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-ES (es_ES)
Comment 5 Robinson Tryon (qubit) 2015-12-13 12:18:27 UTC Comment hidden (obsolete)
Comment 6 Telesto 2016-12-04 10:31:54 UTC
This issue is still reproducible with:
Version: 5.4.0.0.alpha0+
Build ID: 33f5bc54aaa7fe7aa9335726e30f9c349155e04d
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-12-01_23:21:05
Locale: nl-NL (nl_NL); Calc: CL
Comment 7 Yousuf Philips (jay) (retired) 2017-09-29 20:49:54 UTC
I'm assuming this is the XML for the scroll shape.

<w:pict>
 <v:shapetype ... path="m@5,qx@1@2l@1@0@2@0qx0@7@2,21600l@9,21600qx@10@7l@10@1@11@1qx21600@2@11,xem@5,nfqx@6@2@5@1@4@3@5@2l@6@2em@5@1nfl@10@1em@2,21600nfqx@1@7l@1@0em@2@0nfqx@3@8@2@7l@1@7e">
   <v:formulas>
     <v:f eqn="sum height 0 #0" />
     <v:f eqn="val #0" />
     <v:f eqn="prod @1 1 2" />
     <v:f eqn="prod @1 3 4" />
     <v:f eqn="prod @1 5 4" />
     <v:f eqn="prod @1 3 2" />
     <v:f eqn="prod @1 2 1" />
     <v:f eqn="sum height 0 @2" />
     <v:f eqn="sum height 0 @3" />
     <v:f eqn="sum width 0 @5" />
     <v:f eqn="sum width 0 @1" />
     <v:f eqn="sum width 0 @2" />
     <v:f eqn="val height" />
     <v:f eqn="prod height 1 2" />
     <v:f eqn="prod width 1 2" />
   </v:formulas>
   <v:path o:extrusionok="f" limo="10800,10800" o:connecttype="custom" o:connectlocs="@14,0;@1,@13;@14,@12;@10,@13" o:connectangles="270,180,90,0" textboxrect="@1,@1,@10,@7" />
   <v:handles>
     <v:h position="topLeft,#0" yrange="0,5400" />
   </v:handles>
   <o:complex v:ext="view" />
 </v:shapetype>
 ....
</w:pict>

still an issue.

Version: 6.0.0.0.alpha0+
Build ID: 115bed941d7b7ed1b95d6424bfb98456c1d87546
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-09-06_22:52:59
Locale: en-US (en_US.UTF-8); Calc: group
Comment 8 QA Administrators 2018-09-30 02:49:45 UTC Comment hidden (obsolete)
Comment 9 NISZ LibreOffice Team 2020-09-08 08:40:06 UTC
Created attachment 165256 [details]
Minimized test document in docx format

Without text boxes added to scroll shapes the vertical oriented one is not imported correctly, but the horizontally oriented one is.
Comment 10 NISZ LibreOffice Team 2020-09-08 08:41:02 UTC
Created attachment 165258 [details]
Screenshot of the original document side by side in Word and Writer

Still repro with the simplified file in:

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 34a09c9c61bff30e8c4d16132bb47b2b1b16e422
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 11 Xisco Faulí 2021-04-13 10:16:18 UTC
This issue got fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=bda05ba17362222b74727872579b65b3fa14e3d8

Closing as duplicate of bug 41466

*** This bug has been marked as a duplicate of bug 41466 ***
Comment 12 Xisco Faulí 2021-04-13 10:24:33 UTC
In master, there is a problem with the shapes position, but that is another issue. See bug 141675