Bug Hunting Session
Bug 78490 - FILESAVE DATALOSS: exporting spreadsheet with links to outside sheets to XLSX causes the links broken and shows "Err:509" error
Summary: FILESAVE DATALOSS: exporting spreadsheet with links to outside sheets to XLSX...
Status: RESOLVED DUPLICATE of bug 45286
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected
Depends on:
Blocks:
 
Reported: 2014-05-09 14:11 UTC by pharmankur
Modified: 2016-02-22 18:38 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Original file where bug occurs (86.81 KB, application/vnd.ms-excel)
2014-05-09 14:11 UTC, pharmankur
Details
Data is missing when file is saved & reopened (134.00 KB, image/png)
2014-05-09 14:13 UTC, pharmankur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pharmankur 2014-05-09 14:11:57 UTC
Created attachment 98759 [details]
Original file where bug occurs

I am using Libreoffice 4.2.4 

Steps to reproduce:
1. Using Libreoffice 4.2.1; Open the attached file - sales view file - Test.xlsx
2. It will ask 'This file contains links to other files. Should they be updated?'  ... click NO , & It will open showing all the data.
3. type someting in an empty cell & delete is again so that 'Save' option gets enabled. Save the file again & close it.
4. When you open the file again, now the data is missing.

Find attached 
1) sales view file - Test.xlsx
2) the screenshot when file is reopened & data is missing.
Comment 1 pharmankur 2014-05-09 14:13:02 UTC
Created attachment 98760 [details]
Data is missing when file is saved & reopened
Comment 2 m.a.riosv 2014-05-09 23:07:12 UTC
Hi Pharmankur, thanks for reporting.

Reproducible:
Win7x64Ultimate
Version: 3.6.7.2 (Build ID: e183d5b
Version: 4.1.6.2 Build ID: 40ff705089295be5be0aae9b15123f687c05b0a
Version: 4.2.0.4 Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Version: 4.2.3.3 Build ID: 882f8a0a489bc99a9e60c7905a60226254cb6ff0
Version: 4.2.4.2 Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8

With:
LibreOffice 3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
cells with only open the first time with only the equal in the cells.

Formula links are changed, brackets are added.
from
='file:///C:/Users/MARV/Downloads/_Test/Data Final  Sales/Sales Report.xlsx'#$'Hq wise Report'.C73
to
=['file:///c:/users/marv/downloads/_test/data final  sales/sales report.xlsx']$'HQ Wise Report'.C73
Comment 3 Kevin Suo 2014-05-30 07:19:13 UTC
Changing the title summary.
This is a Dataloss, so  Importance-> High/Critical.

Please note that export as ODS format do not broken the links.

Also, mannually chaning the links to
='file:///c:/users/marv/downloads/_test/data final  sales/sales report.xlsx'#$'HQ Wise Report'.C73
will bring the data back again.
Comment 4 Xisco Faulí 2014-05-30 09:47:10 UTC
bibisected:

2da15b0933b13a6a96a60bf2f84cfd1d012051e0 is the first bad commit
commit 2da15b0933b13a6a96a60bf2f84cfd1d012051e0
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Mon Dec 10 09:41:04 2012 +0000

    source-hash-e19f1afb2c253944968f85b963934a60b87f472a
    
    commit e19f1afb2c253944968f85b963934a60b87f472a
    Author:     David Tardon <dtardon@redhat.com>
    AuthorDate: Wed Aug 29 08:20:33 2012 +0200
    Commit:     David Tardon <dtardon@redhat.com>
    CommitDate: Wed Aug 29 08:20:33 2012 +0200
    
        fix typo
    
        Change-Id: Iba7b0c0cf200306d3fc53488021d1e92d8af0e75

:100644 100644 09027be20995113121b74931c4ff6d3f3ce23ba0 f29c164d68e0bc523249aa34a1bbbb7020aafe7d M	autogen.log
:100644 100644 d76f51a6182c67213d6b23c7ba67e1912e29187b de458427013051c636201a33504f8490bfd27e88 M	ccache.log
:100644 100644 a64ed27e1fed93291956b30296fcdecb79da458e a64b6e89c130e3a90478ccf5708c250fc0f834f6 M	commitmsg
:100644 100644 3507edc6b62cc619511f392e87cafd6e7a821910 05064d4c90d81646ee057c533c43e551ae3c58c0 M	dev-install.log
:100644 100644 ea9135b9cc1c8d8bfa7aafddad894e37cd1e07d6 77a0132dc8500835368ae8ccb2f0946fba486cbf M	make.log
:040000 040000 1f62e1208b9310f4bba0b6445b4f1e96ba083a89 1b74dad3797b387afb946a7eb25fe30258c7d925 M	opt

# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# skip: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect skip 8f4aeaad2f65d656328a451154142bb82efa4327
# good: [866567b8f6f645b3fd67aff5e493460c63c5bfa4] source-hash-62f5fc1d2f14f8164c3dd6eca5494a8c1b01301b
git bisect good 866567b8f6f645b3fd67aff5e493460c63c5bfa4
# bad: [85835eaea0e00bbe3138486781a507e436bc9263] source-hash-6978ddbf4738b4c53b9d2edbe6d5ad6a061d0d0f
git bisect bad 85835eaea0e00bbe3138486781a507e436bc9263
# bad: [d36dc3cd85e0b0f13c699c7cdadfde7ab6924a5e] source-hash-d281a19e1d06856f863788f3344ad42ed1566669
git bisect bad d36dc3cd85e0b0f13c699c7cdadfde7ab6924a5e
# bad: [37d651b903e8d0d704f746e27165e92c3333750b] source-hash-9351d0e4181924c3f72be24081fc7af027aa41f7
git bisect bad 37d651b903e8d0d704f746e27165e92c3333750b
# bad: [03a729c328bfa2eafca37f1a2d0796c6575b9e61] source-hash-982b7cb498c3ea1106c5d2184f84989d99b1d942
git bisect bad 03a729c328bfa2eafca37f1a2d0796c6575b9e61
# good: [6d8bd8dba8e0b0a4c2efd95b03c2b5656646bf33] source-hash-a581d31b227623e09d2970a91214fda398f98eda
git bisect good 6d8bd8dba8e0b0a4c2efd95b03c2b5656646bf33
# bad: [cf8644ffc4c66e8567e9c4be706caac879032caf] source-hash-3cf91a21fc5089fb7f051bf8a04d2049da88179f
git bisect bad cf8644ffc4c66e8567e9c4be706caac879032caf
# bad: [2da15b0933b13a6a96a60bf2f84cfd1d012051e0] source-hash-e19f1afb2c253944968f85b963934a60b87f472a
git bisect bad 2da15b0933b13a6a96a60bf2f84cfd1d012051e0
# good: [bf9969effb2f759d95ecbb1a688e25f75a78da16] source-hash-8638f1e72a3fe830c0e8dcc1bd847d4fb9e599ee
git bisect good bf9969effb2f759d95ecbb1a688e25f75a78da16
# first bad commit: [2da15b0933b13a6a96a60bf2f84cfd1d012051e0] source-hash-e19f1afb2c253944968f85b963934a60b87f472a
Comment 5 Yousuf Philips (jay) (retired) 2014-05-30 10:18:15 UTC
Well the root of the problem is that when you save the file Calc is saving it as an XLSX file even though it has an XLS extension. So if you make the change, and then save as an XLS, it will reopen file. Tested in 4.2.4 on Linux.
Comment 6 Yousuf Philips (jay) (retired) 2014-05-30 10:23:29 UTC
But i see that the original file was actually an XLSX renamed as an XLS.
Comment 7 Kevin Suo 2014-05-30 10:55:07 UTC
(In reply to comment #6)
> But i see that the original file was actually an XLSX renamed as an XLS.

No, you are wrong. The original file is an XLSX file. It does not have an XLS extention.

Unzip the file shows:
ContentType="application/vnd.openxmlformats-officedocument.spreadsheetml....

Actually you can reproduce this bug by creating two XLSX files and try to link each other.
Comment 8 m.a.riosv 2014-05-30 13:37:36 UTC
This is and old bug: https://bugs.freedesktop.org/show_bug.cgi?id=45286

*** This bug has been marked as a duplicate of bug 45286 ***
Comment 9 Robinson Tryon (qubit) 2015-12-15 11:03:15 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]
Comment 10 Stéphane Aulery 2016-02-22 17:20:58 UTC
Hello,

This bug is not resolved. Like explained in comment #6, I made two XLSX documents with LO, and linked the second to the first.

When I insert the link, it is ok. If I save, close and reopen the document which contains this link, it is broken. The tooltip display that the path has been corrupted.

It keep file name but drop directories path :

    file:///C:\Users\lkppo\myfile.xslx

become

    file:///myfile.xslx

Tested on Windows 7 64bit with LO 5.0.1.2

Regards,

-- 
Stéphane Aulery
Comment 11 V Stuart Foote 2016-02-22 18:38:07 UTC
Closing this again as duplicate of bug 45286, closed fixed by Eike at 4.3.2 and 4.4.0

Please see new issue in bug 98085 -- FILESAVE as .xlsx destroys link to linked contents

*** This bug has been marked as a duplicate of bug 45286 ***