Download it now!
Bug 78495 - FILESAVE: RTF - Number list indentation not preserved
Summary: FILESAVE: RTF - Number list indentation not preserved
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.2.4.2:OSX
Keywords: filter:rtf
Depends on:
Blocks: RTF-Bullet-Number-Lists
  Show dependency treegraph
 
Reported: 2014-05-09 15:34 UTC by Yousuf Philips (jay) (retired)
Modified: 2020-09-30 17:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
shows how the indent looks like before and after exporting to rtf (146.60 KB, image/jpeg)
2014-05-09 15:34 UTC, Yousuf Philips (jay) (retired)
Details
shows before and after rtf conversion (111.04 KB, image/jpeg)
2014-05-10 09:49 UTC, Yousuf Philips (jay) (retired)
Details
DraftMicrosoftResponsetoGovernment.docx (47.68 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-09-30 17:17 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-05-09 15:34:16 UTC
Created attachment 98767 [details]
shows how the indent looks like before and after exporting to rtf

I download the .docx file found at < http://download.microsoft.com/documents/uk/partner/publicsector/DraftMicrosoftResponsetoGovernment.docx > and opened it in LibO and saved it as an RTF. Then i reopened the RTF file and the number list on page 15 is indented more than the original. The original had indent before text as 0.50" with single line spacing and spacing below paragraph as 0.00", while the RTF had indent before text as 1.00" with fixed line spacing of 0.17" and spacing below paragraph as 0.11".

This was tested in Linux Mint on the last releases from 3.6 to 4.2 and 4.3 alpha. Its a filesave problem as word 2010 shows it the same.
Comment 1 retired 2014-05-10 07:24:21 UTC
Confirmed:4.2.4.2:OSX 10.9.2 -> NEW

open test file in LO, save as rtf, re-open with LO, numbered list is further indented then in the original file.
Comment 2 Yousuf Philips (jay) (retired) 2014-05-10 09:49:28 UTC
Created attachment 98813 [details]
shows before and after rtf conversion
Comment 3 Robinson Tryon (qubit) 2015-12-14 11:26:52 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2017-01-03 19:47:36 UTC Comment hidden (obsolete)
Comment 5 Yousuf Philips (jay) (retired) 2017-09-30 14:12:24 UTC
Still present.

Version: 6.0.0.0.alpha0+
Build ID: 13df3777e4b6ff7537692b396be67a5fd2b9b001
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 6 QA Administrators 2018-10-01 02:52:37 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2020-09-30 17:17:46 UTC
Created attachment 165985 [details]
DraftMicrosoftResponsetoGovernment.docx

The problem is now fixed.

I found the original file via Internet Archive.

Arch Linux 64-bit
Version: 7.1.0.0.alpha0+
Build ID: 09c24681a3414092fde50ec0f617c9f7c79e8a61
CPU threads: 8; OS: Linux 5.8; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 30 September 2020