Bug 78499 - EDITING: Spell check not functioning in windows 7 & 8
Summary: EDITING: Spell check not functioning in windows 7 & 8
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-09 17:54 UTC by DW
Modified: 2014-06-07 21:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DW 2014-05-09 17:54:27 UTC
Problem description: 
A year or more ago I was using a Windows 7 Toshiba. I tried to use Open Office but the spell checker would not work. I then tried to use Libra Office knowing it was based on OO. Unfortunately, the same problem exists in LO as well. I submitted a but then to both OO and to LO. No one ever addressed this problem so I uninstalled both. They are worthless without spell checking.

Now here it is over a year later, I have a new computer an HP with Windows 8.1 and again the latest version of OO or LO spell check does not work. 

Steps to reproduce:
1. ....
Install either OO or LO 
2. ....
Start a new document
3. ....
Turn on auto check or do a manual start of auto check. Neither the auto spell check nor the grammar checker works. I can type in gibberish and still it does not mark it as an unknown word. 

It would sure seem to me that if either OO or LO is going to be serious about competing with MS Word then they would at least have solved this problem, but after all this time it still has the same bug in both versions. Meaning the shared code has the bug in it. 

I cannot afford to buy MS Word or would so I will have to be satisfied using my Old Old MSWorks writer. Pretty good when something this old still works under Win 8.1 but neither OO or LO will.

Current behavior:
It totally ignores any words that are misspelled either intentionally or otherwise. It just does not act like it is even checking at all. Even when I chose to run it from the tool bar it will tell me it is finished spell checking do I want to start from the top. I am at the top already I tell it yes and it tells me there are no misspelled words.
Same action in both OO and LO.
Expected behavior:
I would expect it to spell check and find words that are not spelled correctly. It does not eve see gibberish as wrong. 
Operating System: Windows 8
Version: 4.1.6.2 release
Comment 1 Aniol 2014-05-17 17:41:25 UTC
I have the same error in LibreOffice in 4.2.4.2 version. Also in Windows 8. And the reinstall of version 4.2.3 or 4.2.2 not solved the problem.
I tried to edit the paths of dictionaries and spellcheck at the Options but nothing solved.
Comment 2 DW 2014-05-17 21:32:26 UTC
I have found it really does not do any good to record a bug about either OO or LO, especially this particular bug. I have logged this bug about a year and a half ago. I had the bug on a Windows 7 machine on a totally different laptop than the one I am having it on now. Yet after a year and a half never has anyone from the OO team either contacted me to say they are working on it and the bug still continues. I have seen that there a plenty others who are having this problem yet they still have not addressed it after all this time.

I filed this bug simply because it is still there and I had never been contacted by the OO team to say they even saw my filing. 


If this is the type of response the OPEN SOURCE developers have then how in the world can they rave about how great Open source is? I know out of every bug I have found in a paid piece of software that I have found, even ones that just might be a bother without it affecting the overall operation the paid software people would find and fix the bug is short order. I know this to be the case because I was part of bug fixing teams with, Borland International, Starfish Software / Motorola, and finally MetaWare Inc. Though I am not a coder, I was one of the ones who were responsible to make sure all bugs were fixed in short order. Yes there were bugs that would take long periods of time to fix but it never involved the actually functionality of the software. I hate to tell you this but not having a working spell checker is a show stopper for using the software. I guess I will have to do the Evil thing in Open Source  and forget about OO or LO and go ahead and
 buy MS Office. Bummer, I was hopping Open Source would be a viable option to expensive programs. I guess that was just a pipe dream.


 
David H. Wolfer 
dhwolfer@yahoo.com
On Saturday, May 17, 2014 1:41 PM, "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org> wrote:
 

>
>
> 
>Comment # 1 on bug 78499 from Aniol  
>I have the same error in LibreOffice in 4.2.4.2 version. Also in Windows 8. And
the reinstall of version 4.2.3 or 4.2.2 not solved the problem.
I tried to edit the paths of dictionaries and spellcheck at the Options but
nothing solved.
>________________________________
> You are receiving this mail because: 
>	* You reported the bug.
>
>
Comment 3 Yousuf Philips (jay) (retired) 2014-05-27 14:04:02 UTC
Hey DW,

My friend just confirmed the spell checker is working for him on his Windows 7 PC with LibO 4.2.3.3, so can you give more details about this bug like which language you are running the spell checker with, what you have set under Menu > Tools > Options > Language Settings > Languages > Default Language of Documents > Western (maybe just a printscreen would do here). Alternatively if you can make a screencast that we can see to better identify what the problem is, maybe its something we can fix.

Have you tried clearing your LibreOffice user profile.
< http://ask.libreoffice.org/en/question/903/where-are-the-libreoffice-data-profile-files/ >

(In reply to comment #2)
> If this is the type of response the OPEN SOURCE developers have then how in
> the world can they rave about how great Open source is? I know out of every
> bug I have found in a paid piece of software that I have found, even ones
> that just might be a bother without it affecting the overall operation the
> paid software people would find and fix the bug is short order.

LibreOffice functions with a limited budget and volunteers offer their time to continue its development, which i'm am one of. Unfortunately there are quite a number of bug reports that need to be attended to and sometimes its difficult getting through these reports because unfortunately the bug reporter doesnt provide enough information so that the problem can easily be pinpointed. I'm now tied to this bug report and if your still willing, i'll try my best to get this solved for you. I tried tracking down your older bug report and couldnt find one attached to the < dhwolfer@yahoo.com >, is it possible you used a different email address for that bug report?

(In reply to comment #0)
> I cannot afford to buy MS Word or would so I will have to be satisfied using
> my Old Old MSWorks writer. Pretty good when something this old still works
> under Win 8.1 but neither OO or LO will.

If you cant afford MS Word, have you tried Google Docs, Outlook.com or Kingsoft Office. All are free. :)
Comment 4 Aniol 2014-06-05 22:24:24 UTC
(In reply to comment #3)
> Hey DW,
> 
> My friend just confirmed the spell checker is working for him on his Windows
> 7 PC with LibO 4.2.3.3, so can you give more details about this bug like
> which language you are running the spell checker with, what you have set
> under Menu > Tools > Options > Language Settings > Languages > Default
> Language of Documents > Western (maybe just a printscreen would do here).
> Alternatively if you can make a screencast that we can see to better
> identify what the problem is, maybe its something we can fix.
> 
> Have you tried clearing your LibreOffice user profile.
> <
> http://ask.libreoffice.org/en/question/903/where-are-the-libreoffice-data-
> profile-files/ >

I tried to clearing the LibreOffice user profile and nothing changed. The problem is that I install LibreOffice with Catalan, Spanish, and other dictionaries and spellcheckers but when I try to use this dictionaries are empty. At "share" folder appear some files in "autotext", but nothing in "wordbook" folder. :(
Comment 5 Yousuf Philips (jay) (retired) 2014-06-05 23:04:04 UTC
Try looking in /share/extensions as thats where the dictionary files are stored, so if you have a dict-es folder there, then that means that the spanish dictionary is installed. If thats confirmed, goto Tools > Options > Language Settings > Languages and set 'Local setting' to 'Spanish (Spain)'. Then restart LibreOffice and see if you can get spellchecking for spanish.
Comment 6 Aniol 2014-06-06 18:36:38 UTC
(In reply to comment #5)
> Try looking in /share/extensions as thats where the dictionary files are
> stored, so if you have a dict-es folder there, then that means that the
> spanish dictionary is installed. If thats confirmed, goto Tools > Options >
> Language Settings > Languages and set 'Local setting' to 'Spanish (Spain)'.
> Then restart LibreOffice and see if you can get spellchecking for spanish.

Ok, in /share/extensions are all the files for all the languages that I installed. And when I configure one of this, the Spanish is working well, but not the Catalan. :(
Comment 7 Yousuf Philips (jay) (retired) 2014-06-06 20:33:00 UTC
(In reply to comment #6)
> Ok, in /share/extensions are all the files for all the languages that I
> installed. And when I configure one of this, the Spanish is working well,
> but not the Catalan. :(

When your in the document press F7 and you will find at the top of the spell check dialog, a means of changing the spell check language.
Comment 8 Yousuf Philips (jay) (retired) 2014-06-06 20:41:42 UTC
If only a portion of a document is in another language, then you can highlight that text, right-click and select 'Character' and under the 'Font' tab, select the language in the language drop down menu.
Comment 9 Yousuf Philips (jay) (retired) 2014-06-06 20:50:18 UTC
you should also check in /share/autocorr to make sure you have the necessary auto correct files for the languages.
Comment 10 DW 2014-06-06 20:56:44 UTC
I had uninstalled OO because I had not heard back from anyone. Finally when I did have someone get back to me, I had not had it installed in quite some time. So I went and downloaded the latest version. Previously I had tried everything I could find that was supposed to fix the problem from you support questions and answers / FAQ etc. Nothing worked. I ended up giving up and uninstalling it.
When I received your question on how to reproduce the problem I wen and down loaded the very latest version. After installing it, the problem had been fixed. So I guess you can close that bug. 
Thank you very much.

 
David H. Wolfer 
dhwolfer@yahoo.com


On Friday, June 6, 2014 4:41 PM, "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org> wrote:
 

>
>
Comment # 8 on bug 78499 from Jay Philips  
If only a portion of a document is in another language, then you can highlight
that text, right-click and select 'Character' and under the 'Font' tab, select
the language in the language drop down menu.
________________________________
 You are receiving this mail because: 
	* You reported the bug.
Comment 11 Yousuf Philips (jay) (retired) 2014-06-06 22:10:02 UTC
Hi David,

Glad that you are giving LibreOffice another go. :)

Once Aniol has confirmed that his issue has been solved, i will close the bug.
Comment 12 Aniol 2014-06-07 10:11:57 UTC
(In reply to comment #9)
> you should also check in /share/autocorr to make sure you have the necessary
> auto correct files for the languages.

I have the acor_ca-IS.dat file, but when I use Writer the spellchecker window is not showing any suggestion for any word misspelled.
Comment 13 Yousuf Philips (jay) (retired) 2014-06-07 10:18:50 UTC
Sorry Aniol,

I was mistaken about the /share/autocorr, as that is for automatic corrections per language. /share/extensions is the correct location of the dictionary files. If you right-click in your document and click Character..., in the font tab you will find a language drop down menu, in that list, you will see check marks next to each language which has dictionaries installed.
Comment 14 Aniol 2014-06-07 17:41:50 UTC
(In reply to comment #13)
> Sorry Aniol,
> 
> I was mistaken about the /share/autocorr, as that is for automatic
> corrections per language. /share/extensions is the correct location of the
> dictionary files. If you right-click in your document and click
> Character..., in the font tab you will find a language drop down menu, in
> that list, you will see check marks next to each language which has
> dictionaries installed.

Yes, and Catalan appear installed. But then when I start the spellchecker there are not suggestions in the dictionary.
Comment 15 Aniol 2014-06-07 17:55:21 UTC
(In reply to comment #13)
> Sorry Aniol,
> 
> I was mistaken about the /share/autocorr, as that is for automatic
> corrections per language. /share/extensions is the correct location of the
> dictionary files. If you right-click in your document and click
> Character..., in the font tab you will find a language drop down menu, in
> that list, you will see check marks next to each language which has
> dictionaries installed.

I found the solution in the forums of Softcatalà (who leads the Catalan translation): http://www.softcatala.org/forum/viewtopic.php?f=1&t=5117 There is a problem with the Catalan dictionary, and users have to install the Catalan dictionary extension after the LibreOffice installation.
Finally the spellchecker is working well.
Comment 16 Yousuf Philips (jay) (retired) 2014-06-07 21:09:40 UTC
Glad its now working for you know Aniol.