Download it now!
Bug 78509 - FILEOPEN: MSO ODT - Hyperlink character style incorrectly loaded into one style when actually using another
Summary: FILEOPEN: MSO ODT - Hyperlink character style incorrectly loaded into one sty...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: odf
Keywords: filter:odt
Depends on:
Blocks: ODF-import Hyperlink Writer-Styles-Character
  Show dependency treegraph
 
Reported: 2014-05-09 23:59 UTC by Yousuf Philips (jay) (retired)
Modified: 2020-09-11 14:45 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
word 2013 odt file (44.22 KB, application/vnd.oasis.opendocument.text)
2014-05-09 23:59 UTC, Yousuf Philips (jay) (retired)
Details
how the link shows in word 2013, LibO and calligra words (155.00 KB, image/jpeg)
2014-05-10 00:00 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-05-09 23:59:50 UTC
Created attachment 98794 [details]
word 2013 odt file

I download the .docx file found at < http://download.microsoft.com/documents/uk/partner/publicsector/DraftMicrosoftResponsetoGovernment.docx > and opened it in word 2013 and saved it as an .odt file. I then opened the file in LibO and links found on pages 14, 15, and 17 are in dark blue.

This was tested in Linux Mint on the last releases from 3.6 to 4.2 and 4.3 alpha. It shows in the regular link blue color in calligra words.
Comment 1 Yousuf Philips (jay) (retired) 2014-05-10 00:00:41 UTC
Created attachment 98795 [details]
how the link shows in word 2013, LibO and calligra words
Comment 2 tommy27 2014-05-10 04:26:08 UTC
Ok, this is counterpart of Bug 78514.

I confirm the links in the .odt saved by Word look darker than usual when opened in LibO 4.2.3.3 and AOO 4.1.0

However if you save the original .docx is .odt using LibO there's no color change.

as said in the other report I'm not sure this is LibO fault...
maybe the bug is on MS Word side which fails to correctly save the links color in the .odt format.
Comment 3 Yousuf Philips (jay) (retired) 2014-05-10 09:19:51 UTC
(In reply to comment #2)
> as said in the other report I'm not sure this is LibO fault...
> maybe the bug is on MS Word side which fails to correctly save the links
> color in the .odt format.

Yes as Calligra shows it correctly, i believe it maybe a ms word problem, but just incase, i want to bring it to your attention, as it was related to the other bug. :)
Comment 4 Jorendc 2014-07-19 11:34:22 UTC
I'll mark this one as NEW due the fact I can reproduce this tested using LibreOffice 4.3.0.3.
I'm also not sure this is a OUR issue or the issue of calligra and word. But as far I can see it's 2 against 1, bigger 'chance' it's libreoffice' fault :-).

Kind regards,
Joren
Comment 5 QA Administrators 2015-09-04 02:48:44 UTC Comment hidden (obsolete)
Comment 6 Robinson Tryon (qubit) 2015-12-10 01:42:48 UTC Comment hidden (obsolete)
Comment 7 Oliver Specht (CIB) 2016-04-28 10:51:20 UTC
The related auto style in the odt contains fo:color="#0000FF" which is the same setting as in the docx file: <w:color w:val="0000FF"/>

This is not a bug.
Comment 8 Yousuf Philips (jay) (retired) 2016-04-28 17:06:46 UTC
Reopening as this is a LO bug that is also in AOO and is broken somewhere at the import level.

So the hyperlinks claim to be assigned to the "Default Paragraph Font > Hyperlink" character style which is "Blue 3" (#0000ff), but in actuality they are assigned to the "Internet Link" character style which is "Sky Blue 6" (#000080).

Sample ODF code

<text:span text:style-name="T5">http://blogs.msdn.com/b/officeinteroperability/archive/2013/04/04/microsoft-support-for-pdf.aspx</text:span>

<style:style style:name="T5" style:parent-style-name="Hyperlink" style:family="text"><style:text-properties style:font-size-complex="12pt" /></style:style>

<style:style style:name="Hyperlink" style:display-name="Hyperlink" style:family="text" style:parent-style-name="DefaultParagraphFont"><style:text-properties fo:color="#0000FF" style:text-underline-type="single" style:text-underline-style="solid" style:text-underline-width="auto" style:text-underline-mode="continuous" style:text-underline-color="font-color" /></style:style>

<style:style style:name="DefaultParagraphFont" style:display-name="Default Paragraph Font" style:family="text" />
Comment 9 QA Administrators 2017-05-22 13:40:53 UTC Comment hidden (obsolete)
Comment 10 Yousuf Philips (jay) (retired) 2017-09-30 16:55:08 UTC
Still repo.

Version: 6.0.0.0.alpha0+
Build ID: 13df3777e4b6ff7537692b396be67a5fd2b9b001 [2017-09-29]
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 11 QA Administrators 2019-02-15 03:46:41 UTC Comment hidden (obsolete)
Comment 12 Regina Henschel 2020-09-11 14:45:41 UTC
Works for me in Version: 7.0.0.2 (x64)
Build ID: c01aa64b6c3d89ebe5fe69c28c7adb24eb85249c
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: Skia/Raster; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: CL

The hyperlinks texts have T205 and T207 as automatic styles, which have "DefaultParagraphFont" as parent custom style. And that style is shown in the Stylist.
The links are rendered in #0000FF, so there in neither a problem.