Bug 78612 - build: error ‘xmlChildElementCount’ was not declared in this scope
Summary: build: error ‘xmlChildElementCount’ was not declared in this scope
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected) Master
Hardware: All All
: medium normal
Assignee: Douglas Mencken
Depends on:
Reported: 2014-05-12 16:29 UTC by Douglas Mencken
Modified: 2014-05-14 12:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Douglas Mencken 2014-05-12 16:29:09 UTC
I'm trying to build current master. Since April 26 something was changed.

[build BIN] postprocess
[build MOD] postprocess
[build CXX] test/source/xmltesttools.cxx
/Volumes/lo-build/test/source/xmltesttools.cxx: In member function ‘void XmlTestTools::assertXPathChildren(xmlDoc*, const rtl::OString&, int)’:
/Volumes/lo-build/test/source/xmltesttools.cxx:77: error: ‘xmlChildElementCount’ was not declared in this scope
make[1]: *** [/Volumes/lo-build/workdir/CxxObject/test/source/xmltesttools.o] Error 1
Comment 1 Terrence Enger 2014-05-12 22:04:39 UTC

First you, might try to `git pull` and build again.  If the problem
persists ...

You will probably get a faster answer by sending your question to the
dev list; this list available through nabble
<http://nabble.documentfoundation.org/Dev-f1639786.html> or the list
of LibreOffice mail lists
<http://www.libreoffice.org/get-help/mailing-lists/>.  Please tell us
the commit id that you are trying to build, the platform you are
building on, and the contents of your autogen.lastrun.

FWIW, on my debian-wheezy 64-bit, xmlChildElementCount is defined in
/usr/include/libxml2/libxml/tree, line 1236.

Comment 2 Douglas Mencken 2014-05-14 10:56:36 UTC
First I tried commit 867aa217e6bcb543, now I tried commit a93bb27aa46c8441.
Problem is still here.

I'm building on Mac OS X 10.5 @PowerPC.


--with-build-version=Built by Douglas Mencken for PowerPC
--with-vendor=Unaffiliated Hackers
Comment 3 Douglas Mencken 2014-05-14 11:09:40 UTC
checking which libxml to use... external

xmlChildElementCount was introduced with libxml2 2.7.3.
Looks like my "external" one is older than that.

Need to modify configure.ac to use bundled version of libxml2 and libxslt instead of system's.
Comment 4 Douglas Mencken 2014-05-14 11:15:31 UTC
Assigning this to myself.