Bug Hunting Session
Bug 78622 - LibreLogo: change in tooltips
Summary: LibreLogo: change in tooltips
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:4.5.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-12 18:58 UTC by Gilvan Vilarim
Modified: 2015-03-03 13:40 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreLogo help article wef 4.4.0 (28.03 KB, application/vnd.oasis.opendocument.text)
2015-01-11 22:36 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gilvan Vilarim 2014-05-12 18:58:29 UTC
Logo toolbar contains buttons with the following text:
forward
backward
right
left

I suggest to explicitally show the parameters used with these buttons, like these:
FORWARD 10
BACKWARD 10
RIGHT 15º
LEFT 15º

Best regards,
Gilvan.
Comment 1 Yousuf Philips (jay) (retired) 2014-06-07 14:03:32 UTC
I think the buttons are being true to the commands they represent when a user is typing them, so i dont think it needs to be elaborated in the tooltips.

@jmadero & @qubit: What do you think?
Comment 2 Robinson Tryon (qubit) 2014-06-07 15:00:34 UTC
(In reply to comment #0)
> Logo toolbar contains buttons with the following text:

Repro Steps:
- Enable the Logo toolbar via the menu: View -> Toolbars -> Logo
- See how the buttons look
- See the button tooltips

(In reply to comment #1)
> I think the buttons are being true to the commands they represent when a
> user is typing them, so i dont think it needs to be elaborated in the
> tooltips.
> 
> @jmadero & @qubit: What do you think?

Testing Version: 4.3.0.0.beta1 + Ubuntu 12.04.4

The button icons seem decent to me, however when they are docked next to other toolbars it isn't immediately obvious that they are intended for LOGO purposes. For example, the icons for "Left" and "Right" look very similar to the icons for "Undo" and "Redo".

As for the tooltip text, some of it is rather confusing. There's a button of an empty page with tooltip "Clear Screen"; it's kind of confusing that pressing that button doesn't clear the screen/page in Writer.

One possible solution would be to put a little turtle graphic (e.g. an isosceles triangle) in the corner of each LOGO-related button. I'd also suggest that each tooltip be made more LOGO-descriptive. Even "FORWARD 10" might be confusing unless it's "LOGO: FORWARD 10" or "Move LOGO turtle FORWARD 10"
Comment 3 Yousuf Philips (jay) (retired) 2014-06-07 15:12:24 UTC
(In reply to comment #2)
> As for the tooltip text, some of it is rather confusing. There's a button of
> an empty page with tooltip "Clear Screen"; it's kind of confusing that
> pressing that button doesn't clear the screen/page in Writer.

The "Clear Screen" tooltip and button equal to the logo 'CLEARSCREEN' command which clears the output of the logo turtle.

> One possible solution would be to put a little turtle graphic (e.g. an
> isosceles triangle) in the corner of each LOGO-related button. I'd also
> suggest that each tooltip be made more LOGO-descriptive. Even "FORWARD 10"
> might be confusing unless it's "LOGO: FORWARD 10" or "Move LOGO turtle
> FORWARD 10"

I would suggest the toolbar would have a turtle as its first icon in the toolbar, so when its docked it easily understandable that everything else in the toolbar is logo related, as a turtle graphic in each icon will not be visible in the small icon size.
Comment 4 Joel Madero 2014-06-07 16:53:03 UTC
I know nothing about LibreLogo - that's why I added nemeth to the cc as he's the one with the knowledge here
Comment 5 Gilvan Vilarim 2014-06-10 22:13:32 UTC
I understand that the tooltips are one thing, and the button images are something else. Button images seems ok to me.

Some buttons represent commands that can be typed in LibreLogo. So, I think it would be more consistent to use a more precise tooltip. There is no way to type FORWARD without parameters; so, it would be better to use a tootip with "FORWARD 10", since the turtle moves 10 pts with this button.

About buttons, I agree that it could be confusing for the newbies to show the Logo toolbar and see these buttons next to the "normal" buttons. One suggestion is to include a new button in Logo bar to be the first button, with the image of a turtle. This button could be used to open the Logo help screen.

[]s
Comment 6 QA Administrators 2015-01-10 18:07:09 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

Message generated on: 10/01/2015
Comment 7 Robinson Tryon (qubit) 2015-01-10 22:42:19 UTC
I think the NEEDINFO part was answered.

Status -> UNCONFIRMED

That being said, this sounds like a UX decision, so handing it to them to triage
Component - > ux-advise
Status -> NEW
Comment 8 Yousuf Philips (jay) (retired) 2015-01-11 21:54:39 UTC
@Stuart, @Heiko: What do you think of the changing of these tooltips?
Comment 9 V Stuart Foote 2015-01-11 22:36:56 UTC
Created attachment 112099 [details]
LibreLogo help article wef 4.4.0

I'd tend to agree with OP.

The LibreLogo command should be used as the tool-tip for these buttons.

so:
   FORWARD 10
   BACKWARD 10
   LEFT 15°
   Right 15°

From the LibreLogo help (attached):

"Turtle moving icons:--
They are equivalents of the Logo commands “FORWARD 10”, “BACK 10”, “LEFT 15”, “RIGHT 15”. Clicking on one of the icons will also focus the turtle shape scrolling the page to its position."

Also, since this is kind of specialized educational function--some redesigned "Turtle" specific icons would probably be appropriate.
Comment 10 Heiko Tietze 2015-01-11 23:03:21 UTC
The suggestion sounds reasonable. But I never tried this extension.
Comment 11 Yousuf Philips (jay) (retired) 2015-03-02 02:37:18 UTC
Patch has been sent in. https://gerrit.libreoffice.org/14702

As these tooltips are actual programming commands, i believe they should not be translated. @Stuart: Do you know what i have to do to make it not translatable.

This fix only fixes the tooltips, but i dont have any experience in adding the turtle icon.
Comment 12 Adolfo Jayme 2015-03-02 03:24:29 UTC
(In reply to Jay Philips from comment #11)
> As these tooltips are actual programming commands, i believe they should not
> be translated.

If you have ever worked with a Logo-like programming language, you will have known who is the intended audience of it. These programming languages are translated, as they should. And LibreLogo is already localized for a number of languages.
Comment 13 Commit Notification 2015-03-03 09:47:24 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1b50aa9555f8be819759ab5600eb9830bbe7ca3c

tdf#78622 Fix LibreLogo tooltips

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Gilvan Vilarim 2015-03-03 13:40:23 UTC
Thanks! By the way, see if this annoying bug has something to do with some xml mistake:

https://bugs.documentfoundation.org/show_bug.cgi?id=72438

Best regards.