Bug 78668 - EDITING: Calc image anchor bug
Summary: EDITING: Calc image anchor bug
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Anchor-and-Text-Wrap Paste Calc-Images
  Show dependency treegraph
 
Reported: 2014-05-13 16:52 UTC by geomaticien
Modified: 2020-03-04 07:29 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Image showing anchor in a wrong cell just after pasted (5.30 KB, image/png)
2014-05-13 16:52 UTC, geomaticien
Details
Image anchored correctly (124.08 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-05-16 20:58 UTC, Joel Madero
Details
Reproduced the bug with the given file (119.32 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-05-18 21:33 UTC, geomaticien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description geomaticien 2014-05-13 16:52:56 UTC
Created attachment 98986 [details]
Image showing anchor in a wrong cell just after pasted

Test case : 
- resize columns and lines (bigger than default)
- add a drawing (any)
- anchor to cell
- copy the drawing
- paste it into a cell (at the right and under the re-sized lines/columns)

Result : the anchor is positioned in a wrong cell (the upper cell and/or in the left cell, depending on the resizing done previously).

Expected result : the pasted drawing should be anchored to the cell where the drawing is pasted into.
Comment 1 Joel Madero 2014-05-16 20:57:34 UTC
Cannot reproduce:
Ubuntu 14.04x64
LibreOffice 4.2.4.2 release

Please attach a document that shows the anchor incorrectly (the original document). Also if possible please try with a fresh profile: https://wiki.documentfoundation.org/UserProfile


Marking as NEEDINFO - if you can still reproduce with a fresh profile please attach a document that shows the anchor wrong and mark the bug as UNCONFIRMED. Thanks!
Comment 2 Joel Madero 2014-05-16 20:58:05 UTC
Created attachment 99176 [details]
Image anchored correctly
Comment 3 geomaticien 2014-05-18 21:33:02 UTC
Created attachment 99283 [details]
Reproduced the bug with the given file

I took the file "GoodAnchor.ods", resized a line, added a column, and reproduced the bug y copying and pasting the image : the anchor is in a wrong cell.
Comment 4 Joel Madero 2014-05-19 06:04:42 UTC
In the future please read entire post - marking as UNCONFIRMED (otherwise QA will never look at it). Thanks!
Comment 5 geomaticien 2014-05-19 12:44:40 UTC
I have NOT changed the bug status. Sorry. Can you now confirm the bug when you copy/paste the image at the bottom right of the attached file ? (your file with re-sized lines and columns).
Comment 6 raal 2014-10-07 20:47:12 UTC
I can not confirm with LO 4.2.6, 4.3.3.0.0+, 4.4.0.0.alpha0+ ; Linux
@geomaticien: Please test with newer version of LO.
Comment 7 geomaticien 2014-10-19 20:17:11 UTC
This bug also occurs with LO 4.1.6.2, which is the version released with the latest OpenSUSE stable release (13.1). 
The stable version of Libre Office in stable versions of majors Linux distributions MUST be taken into account, and debugged, as these is the LO current version used by all users except LO developers.
Comment 8 A (Andy) 2014-10-24 20:50:32 UTC
Reproducible with LO 4.3.2.2 (Win 8.1)

Note: To reproduce it you need to paste it in the same column under the image or in the same row on the right of the image.  If you paste it to another cell it is not reproducible.
Comment 9 QA Administrators 2015-12-20 16:12:00 UTC Comment hidden (obsolete)
Comment 10 A (Andy) 2015-12-26 22:15:59 UTC
Still reproducible with LO 5.1.0.1, Win 8.1 if you paste it into the cell on the right of the cell.
Comment 11 QA Administrators 2017-01-03 19:57:38 UTC Comment hidden (obsolete)
Comment 12 Regina Henschel 2017-12-19 17:02:46 UTC
Still reproducible with Version: 6.1.0.0.alpha0+ (x64)
Build ID: d73857e7d7f6a5bf38c6a2f396832faabaef65e2
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2017-12-12_17:37:14
Locale: de-DE (de_DE); Calc: CL
Comment 13 QA Administrators 2018-12-20 03:56:26 UTC Comment hidden (obsolete)
Comment 14 Samuel Mehrbrodt (CIB) 2020-03-04 07:29:31 UTC
This looks fixed in current master.