Download it now!
Bug 78671 - FILEOPEN: DOCX - Textbox that should appear on a page of its own is appearing overlapping text on the second page
Summary: FILEOPEN: DOCX - Textbox that should appear on a page of its own is appearing...
Status: RESOLVED DUPLICATE of bug 120511
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2014-05-13 18:33 UTC by Konstantin Svist
Modified: 2019-10-08 12:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
incorrectly rendered file (12.82 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-05-13 18:33 UTC, Konstantin Svist
Details
sample document (27.34 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-07-21 01:04 UTC, Konstantin Svist
Details
sample doc (27.34 KB, application/wps-office.docx)
2017-07-21 19:05 UTC, Yousuf Philips (jay) (retired)
Details
sample doc with the removal of the textbox (26.35 KB, application/wps-office.docx)
2017-07-21 19:08 UTC, Yousuf Philips (jay) (retired)
Details
Screenshot of the problem in Writer 6.3 alpha (140.57 KB, image/png)
2019-10-08 12:29 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Svist 2014-05-13 18:33:12 UTC
Created attachment 98992 [details]
incorrectly rendered file

Using Fedora 20, LibreOffice Version: 4.2.4.2 Build ID: 4.2.4.2-8.fc20

Attached file shows 1st page overlaying the 2nd page. Google docs display the 1st page* separately, as expected.

* of original document. Attached file was edited with same LibreOffice version to cut off all pages after 3rd. I could provide original document for debugging, but it should not be made available to the public.
Comment 1 sophie 2014-05-26 14:42:35 UTC
Hi, confirmed using Version: 4.3.0.0.beta1
Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f and Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8 on Ubuntu 14.04 x64. 
The document shows only one page and what seems to be the first page is a frame anchor to the page. Set as New - Sophie
Comment 2 Konstantin Svist 2014-11-07 01:56:01 UTC Comment hidden (no-value)
Comment 3 QA Administrators 2015-12-20 16:07:42 UTC Comment hidden (obsolete)
Comment 4 Konstantin Svist 2015-12-30 21:41:56 UTC
Using Fedora 23's version,
Version: 5.0.4.2
Build ID: 5.0.4.2-3.fc23
Locale: en-US (en_US.utf8)

The attached file (and original document) are still rendered incorrectly (single page, 1st page overlays on top of 2nd page content
Comment 5 Yousuf Philips (jay) (retired) 2017-07-18 18:45:24 UTC
(In reply to Konstantin Svist from comment #0)
> Created attachment 98992 [details]
> incorrectly rendered file

We need to original document and not the one modified within LibreOffice, as LibreOffice opens the attached document exactly the same way as the document opens in MS Word 2010.

So modify the original document in the original application it was created in (i'm assuming it was Google Docs) and shrink it down to two pages and then attach that document so that we can determine where the problem originates. Alternatively, you can email me the original document and it wont be shared with the QA team and not shared publicly.
Comment 6 Konstantin Svist 2017-07-18 19:22:01 UTC
@Yousuf I just sent you the files over email
Comment 7 Konstantin Svist 2017-07-21 01:04:47 UTC
Created attachment 134754 [details]
sample document

With Yousuf's help prepared another sample
Comment 8 Yousuf Philips (jay) (retired) 2017-07-21 19:05:51 UTC
Created attachment 134773 [details]
sample doc
Comment 9 Yousuf Philips (jay) (retired) 2017-07-21 19:08:53 UTC
Created attachment 134774 [details]
sample doc with the removal of the textbox
Comment 10 Yousuf Philips (jay) (retired) 2017-07-21 19:12:03 UTC
So LO incorrectly renders the first page of attachment 134773 [details] which has the textbox, but if the textbox is removed as in attachment 134774 [details], LO correctly renders the first page.

Version: 6.0.0.0.alpha0+
Build ID: e0bafa78e3ad0df397d78cd65ad19bd5b07dc5f2
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 11 QA Administrators 2018-07-22 02:37:36 UTC Comment hidden (obsolete, spam)
Comment 12 Justin L 2018-08-11 15:38:02 UTC
this is a weirdly designed document. The entire first page is an autoshape set as behind text (background/wrap through. The only reason Word displays it this way is because there is a section break/next page. My guess is that the root cause is related to an empty paragraph getting removed (nope - not bRemove) or a section break problem.
Comment 13 Justin L 2018-08-11 16:28:39 UTC
The shape must be absorbing the PROP_PAGE_DESC_NAME property. If you remove the autoshape, then the page-break shows up and page2 contents are on page2 with an essentially empty page1.
Comment 14 NISZ LibreOffice Team 2019-10-08 12:29:10 UTC
Created attachment 154832 [details]
Screenshot of the problem in Writer 6.3 alpha

The original document appears on two pages since:

Version: 6.3.0.0.alpha0+
Build ID: 6aeba04b31cc33135f84bd7ea38a04ee9faa14ec
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded

author
Justin Luth <justin_luth@sil.org> Sat Dec 29 18:50:18 2018 +0300 
committer
Justin Luth <justin_luth@sil.org> Sat Dec 29 19:25:58 2018 +0100 

tdf#120511 writerfilter: track inserted frame per section
Comment 15 NISZ LibreOffice Team 2019-10-08 12:41:41 UTC
Let's mark this as duplicate for simplicity.

*** This bug has been marked as a duplicate of bug 120511 ***